Graphics feature tests are too strict

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: marcia, Assigned: bjacob)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [4b3], URL)

Attachments

(1 attachment, 2 obsolete attachments)

Seen while running  Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3) Gecko/20100805 Firefox/4.0b3. I tried in 32 bit mode and the same thing happens.

STR:
1. Enable WebGL with the about:config pref
2. Load the site in the URL, or one of the demos from http://www.ambiera.com/copperlicht/demos.html

Expected: it would work as it does using Windows XP and Vista using the same build
Actual: I get an error saying that "This demo requires a WebGL-enabled browser"

I have seen Bug 560975 and I do not have those prefs set in about:config since I am using a new profile.
I tested this on my HP TouchSmart tx2 laptop which runs Windows 7 and that machine loads the sites such as https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/demos/google/particles/index.html fine. Perhaps this is hardware related?
(Assignee)

Comment 2

7 years ago
What is the graphics card in the machine that can't run WebGL demos?

Comment 3

7 years ago
Since 20100917 build, I have the same issue with a new profile.
I checked that webgl.enabled_for_all_site is set to true.
It seems to be linked to bug 594874 fix.

Every Intel card as been declared as "Webgl not recommended", so webgl is not enabled. 
Either, "webgl not recommended" status must not disabled webgl, or at least some recent graphic cards must have "webgl available" status.

Adapter Description : Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID : 8086
Device ID : 2a42
Adapter RAM : Unknown
Adapter Drivers : igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version : 8.15.10.2202
Driver Date : 8-25-2010
Direct2D Enabled : true
DirectWrite Enabled : true
GPU Accelerated Windows1/1 Direct3D 9
(Assignee)

Updated

7 years ago
Component: Canvas: WebGL → Graphics
QA Contact: canvas.webgl → thebes
Summary: [Win7] WebGL demos give me "This demo requires a WebGL-enabled browser" → Graphics feature tests are too strict
(Assignee)

Comment 4

7 years ago
Created attachment 476323 [details] [diff] [review]
relax graphics feature tests

OK, indeed our feature tests were too strict in that "not recommended" ended up blocking. This patch relaxes them so we only block when the feature is really blocked or not available.
Assignee: nobody → bjacob
Status: NEW → ASSIGNED
Attachment #476323 - Flags: review?(vladimir)
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
(Assignee)

Comment 5

7 years ago
Marcia: still need to know what's your graphics card! If it's Intel and doesn't have GL drivers on Windows, then your issue is a dupe of the fact that we need to use ANGLE in your case (known issue).
(Assignee)

Comment 6

7 years ago
Created attachment 476815 [details] [diff] [review]
relax WebGL feature test

ok, let's play safe and only do this for WebGl.
Attachment #476323 - Attachment is obsolete: true
Attachment #476815 - Flags: review?
Attachment #476323 - Flags: review?(vladimir)
(Assignee)

Comment 7

7 years ago
Created attachment 476827 [details] [diff] [review]
relax WebGL feature test

Regenerated the patch (line ending issue)
Attachment #476815 - Attachment is obsolete: true
Attachment #476827 - Flags: review?(joe)
Attachment #476815 - Flags: review?
Attachment #476827 - Flags: review?(joe) → review+
blocking2.0: ? → betaN+
(Assignee)

Comment 8

7 years ago
http://hg.mozilla.org/mozilla-central/rev/901fd772c4da
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Blocks: 594025
You need to log in before you can comment on or make changes to this bug.