Closed Bug 585870 Opened 12 years ago Closed 12 years ago

Awesomebar's 'I'm feeling Lucky' results don't provide an easy way back to the general search

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: scott.g.newson, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.477.0 Safari/534.3
Build Identifier: 

When entering a common term in the awesomebar and it jumps directly to a website, there is no easy way to go 'back' to just the google search of that term. Instead, one has to re-type the search terms in the search bar.

Reproducible: Always

Steps to Reproduce:
1. New tab in Firefox
2. Type a search term such as 'Facebook' into the awesomebar ('Facebook' works on my computer, you might have to find a different one)
3. Press enter
Actual Results:  
You will now be at the Facebook webpage, but there is no easy way to get to the google results of 'Facebook'. You either have to go to the google search page, or use the search toolbar in Firefox. Both of these require typing the search terms again (and remembering them!) which gets more bothersome as the length of the serach terms increase.

Expected Results:  
I would expect the awesomebar to work exactly the same way, but with one change. When at the 'I'm feeling Lucky' result (facebook.com in the example above), I want to press the back button in the browser to go 'back' to the google search. I don't want to actually go to the google search at any point, unless I don't like the 'I'm feeling Lucky' and have pressed the back button.

Not a technical bug. Nothing crashes. But it's a real pain.
Component: General → Location Bar
Duplicate of this bug: 584417
Another possibility is to let one of the options that appear underneath the URL (similar to "Switch to Tab"): search Google for this term.
I'll try taking this bug on myself in a couple weeks when I finish my current job. I've been meaning to explore the code for firefox and now, having worked in on a large software project, I might be able to figure it out.
QA Contact: general → location.bar
In the latest version of Firefox we don't use Browse By Name anymore, so this doesn't actually apply. INVALID sounds harsher than I mean the resolution to be: it's actually FIXED by bug 565966
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.