Visual tab interface behaving oddly when moving items to the right.

RESOLVED DUPLICATE of bug 587503

Status

Firefox Graveyard
Panorama
RESOLVED DUPLICATE of bug 587503
8 years ago
2 years ago

People

(Reporter: Matthew Galloway, Assigned: iangilman)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100808 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100808 Minefield/4.0b4pre

See video:
http://www.youtube.com/watch?v=dvqCfjGFekg

It seems that I can't drop items onto the rightmost end of the group of tabs. If I have a lot of blank space in the group to the right of the open tabs, I can't simply drop a tab from that group into the whitespace; either the move fails or the tab is places in the next-to-last position instead of the last position.
Moving things to the left works as expected 95% of the time. 

Reproducible: Always

Steps to Reproduce:
1. Open a bunch of tabs in one group
2. Make the tab grouping box large in the width direction
3. Try to move a tab from the left end of the group to the right
Actual Results:  
Move fails, or tab moves to the wrong spot.

Expected Results:  
Tab gets moved to the end of the list.

Built from: http://hg.mozilla.org/users/edward.lee_engineering.uiuc.edu/tabcandy-central/rev/73cccee13d8b

Comment 1

8 years ago
I can confirm this bug. Although it does appear to happen sometimes when moving the other direction.
Assignee: nobody → ian
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All

Comment 2

8 years ago
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk

Updated

8 years ago
QA Contact: tabcandy → tabcandy
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587503
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.