location.replace(url) must be called twice before page will load again

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
18 years ago
18 years ago

People

(Reporter: wcd, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
MULTI-FRAME ENVIRONMENT...

I have a scripted page which is effectively "self modifying" through a call to 
a function in the base frame. This function uses document.write to create part 
of the page content on the fly ... the vast majority of the page is just plain 
HTML 4.01.

If a function is called that attempts to reload the window with the document 
from the same URL using location.replace(url) the first call results in the 
document in the frame scrolling to the top of the page as if it were locally 
refreshed from the cache.

The second call has the desired effect -  the page completely reloads and 
generates new content based on variables that have been set in the base frame 
by other user actions.

A 'NASTY' workaround is to append a dynamically constructed query string based 
on the current time to the url.

i.e. location.replace(url) ... requires two goes.

location.replace(url + "?" + myTime) works every time, albiet at the expense of 
reloading the entire page from the web-server each time it is called.

IE45 and NS4 do not have this problem; ANY call to location.replace(url) will 
replace the page from the contents of the cache.

Updated

18 years ago
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale

Comment 1

18 years ago
Over to DOM
(Assignee)

Comment 2

18 years ago
We need a testcase that shows this problem in order to look into possible
sollutions, could you attach a testcase to this bug? Thanks!
(Reporter)

Comment 3

18 years ago
OK - Will take a bit of time to construct a simple test case due to need to 
construct a frameset. I will put this on my list of things to do before the end 
of the week.

Comment 4

18 years ago
Is anyone still seeing this problem?

Comment 5

18 years ago
Marking INVALID due to lack of Response. Reopen if this is still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.