If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Never Remember History Not Honored

RESOLVED WORKSFORME

Status

()

Firefox
Private Browsing
--
major
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: darin-mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20121012])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre

I have "Never Remember History" selected. When I restart the application, all cookies are remembered from the last session.

Reproducible: Always

Steps to Reproduce:
1. Clear your current history and all cookies -- all private data.
2. Go to a website that sets a cookie.
3. Exit the application.
4. Restart the application.
5. Look at your list of cookies; all cookies still exist.
Actual Results:  
Cookies are retained.

Expected Results:  
Cookies should be deleted.

Comment 1

7 years ago
Some sites regenerate cookies based on flash 'cookies' does this go away if you disable all plugins? Tools > addons > plugins
(Reporter)

Comment 2

7 years ago
Weird. I did everything I could to clear my history, including explicitly deleting cookies. Every time I restarted the application, my cookies returned. I finally forced them to go away by entering Private Browsing Mode, then exiting again. Now, cookies seem to be deleted properly upon restart. It may be a one-time glitch, but it's probably something to keep an eye on.
(Reporter)

Comment 3

7 years ago
It wasn't regenerating cookies from Flash -- all I had to do was restart Minefield, then view my cookies. They returned with a vengeance, even before hitting a page. (I have Firefox to start with an empty page, so I was guaranteed to not trigger a cookie setting.)
If you set your browser to "never remember history", Firefox will start in private browsing mode by default.  When you said in comment 2 that the issue was apparently fixed by entering private browsing mode, how were you trying to enter that mode?  The Tools > Start Private Browsing menu item should be disabled in "never remember history" mode.
Tested on 
Name : Firefox
Version : 19.0a1
User Agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID : 20121012030610


You can try with the website  http://dottorato.unipi.it/

Steps to Reproduce:

1. Firefox -> Preferences -> Privacy -> History -> remember history (so you can clear recent history)
2. Clear your current history and all cookies -- all private data.
3. Firefox -> Preferences -> Privacy -> History -> Never Remember History
4. Go to a website that sets a cookie. (I tried with http://dottorato.unipi.it/ )
5. Exit the application.
6. Restart the application.
7. Firefox -> Preferences -> Privacy -> History -> Use custom settings for history
8. Look at your list of cookies; all cookies still exist.

Actual Results:  
Cookies are retained.

Expected results:
Cookies should not be retained

I leave unconfirmed, don't know what to do.
Whiteboard: [testday-20121012]
I cannot reproduce this.  Are you using a clean profile?
I couldn't reproduce this with a clean profile with no extensions on Firefox Aurora. I opened many sites while I was in the "Never Remember History" state, including Federico's sample, google, NYT, and Yahoo pages, but no cookies were retained.
Federico, are you able to reproduce this with a clean profile and in safe mode? Thanks very much!
Flags: needinfo?(federico_padua)
Note that this bug happened with the global PB mode, and that mode does not exist any more.  Given that and the fact that nobody has managed to reproduce it so far, I'll call it WORKSFORME.  Please reopen if this happens with per-window PB as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 10

4 years ago
(In reply to Liz Henry :lizzard from comment #8)
> Federico, are you able to reproduce this with a clean profile and in safe
> mode? Thanks very much!
I did. Firefox 22 and 23 on a linux machine. Reported a new bug but can't find it anywhere. I'm new to bugzilla...
Flags: needinfo?(federico_padua)
You need to log in before you can comment on or make changes to this bug.