Closed Bug 586194 Opened 11 years ago Closed 11 years ago

move never pref check into selectUpdate and use services js module in app update

Categories

(Toolkit :: Application Update, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

Attachments

(1 file, 1 obsolete file)

The never pref check should be in selectUpdate since the never button can now be shown for both minor and major updates. I also would like to make app update use the services js module but can move that to a separate bug if preferred.
Attached patch patch rev1 with test (obsolete) — Splinter Review
Attachment #464745 - Flags: review?(dtownsend)
Attached patch patch rev2Splinter Review
After thinking about it I don't think the never pref should be cleared for background updates and instead it should just be ignored if the update doesn't specify showNeverForVersion.
Attachment #464745 - Attachment is obsolete: true
Attachment #464759 - Flags: review?(dtownsend)
Attachment #464745 - Flags: review?(dtownsend)
btw: do you think the new test would be better as an xpcshell test? I should be able to test no updates due to the pref that way
Comment on attachment 464759 [details] [diff] [review]
patch rev2

I think the test is fine as-is
Attachment #464759 - Flags: review?(dtownsend) → review+
Comment on attachment 464759 [details] [diff] [review]
patch rev2

Drivers, this adds a better solution for bug 350636 and makes app update use Services.jsm as much of the other code base has recently done.
Attachment #464759 - Flags: approval2.0?
Attachment #464759 - Flags: approval2.0? → approval2.0+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/c727df97c28c
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Duplicate of this bug: 350632
You need to log in before you can comment on or make changes to this bug.