(youtube) WebM playback is slow on my Linux Box

VERIFIED DUPLICATE of bug 581797

Status

()

Core
Audio/Video
VERIFIED DUPLICATE of bug 581797
8 years ago
7 years ago

People

(Reporter: Kami, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b4pre) Gecko/20100809 Ubuntu/10.04 (lucid) MozillaDeveloperPreview/4.0b4pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b4pre) Gecko/20100809 Ubuntu/10.04 (lucid) MozillaDeveloperPreview/4.0b4pre

Hello!

I have ASUS X71 laptop (ATI Mobility Radeon 3470) with Ubuntu 10.04 (and the latest developer X with open source radon driver)

The playback of WebM videos on youtube is really slow I got around 1 FPS.

For example this wideo is ok:
http://lachy.id.au/lib/media/elephantsdream/Elephants_Dream-360p-Stereo.webm

I tried on Windows XP (same machine) and youtube videos are OK there.


Reproducible: Always
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
This could be a duplicate of bug 581797.
Are you still seeing this problem?
(Reporter)

Comment 3

7 years ago
Sorry, I will check this issue, today.
Did you have a chance to retest this yet?
(Reporter)

Comment 5

7 years ago
Oh sorry Matthew,

I checked on another machine (Ubuntu 10.10/64 bit) propertary nvidia driver (nVidia Corporation GF104 [GeForce GTX 460] (rev a1)) - Driver version: 173.14.28-0ubuntu1
FF: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b13pre) Gecko/20110301 Firefox/4.0b13pre

The 720 is okay, I have only problem with full screen videos. When I get to home I will check the machine that I used originally. (Now I am using propertary drivers on that machine, first I test it, then with opensource if you ask me)
(Reporter)

Comment 6

7 years ago
I tested on same machine with updated drivers, layers.acceleration.force-enabled true:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b13pre) Gecko/20110301 Firefox/4.0b13pre | NVIDIA-Linux-x86_64-270.26 | GPU Accelerated Windows1/1 OpenGL

Fullscreen is also okay.
(Reporter)

Comment 7

7 years ago
Disabling layer acceleration also makes 720p fullscreen video jerky.
Thanks for testing.

The machine you tested this time has NVIDIA graphics, whereas machine used when opening the bug had ATI graphics... given that the symptoms sounded like bug 581797 (which is more or less ATI specific), I wouldn't expect the machine you're testing on now to suffer from the same bug.  Are you able to retest on the machine with ATI graphics and confirm video playback is improved?

It's expected that fullscreen will be slow if you don't have HW acceleration because software colour conversion and scaling is fairly slow, so what you mentioned regarding that sounds like expected behaviour.
(Reporter)

Comment 9

7 years ago
Hi,

It is interesting, I tested my ATI laptop with propertary driver (11.01) and it seems the problem gone. Using 720p youtube video, the playback was near perfect (rare small pause in playback occured but looks much better - it is enjoyable) I wonder It was also near perfect in full screen mode. So I think it is okay (at least) for me. I switcehd to propertary driver, should I test with OpenSource driver that was in the original report.

Only one question: I tried to enable and force layer acceleration but GPU Accelerated Windows OpenGL still said it is 0, disabled... May I open another bug for this?
That bug only occurred with the "radeon" driver, so your results make sense.  I don't think it's necessary to test with that driver again now, since from the information you've given it sounds very much like the problem only existed with that configuration.  I'll go ahead and mark this bug as a duplicate of that one.

Regarding enabling acceleration, you're probably hitting bug 624390.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581797
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

7 years ago
Okay, I tested with radeon (OS) driver on the original laptop, and the problem is solved. Thank you!

KAMI
You need to log in before you can comment on or make changes to this bug.