Restore hidden tabs after visible ones

VERIFIED FIXED in Firefox 4.0b5

Status

()

Firefox
Session Restore
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Mardak, Assigned: dwitte@gmail.com)

Tracking

({regression})

Trunk
Firefox 4.0b5
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta5+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Bug 586147 adds storing and restoring of the hidden attribute on tabs. Bug 480148 added logic to show visible tabs before those that aren't visible (on the tab strip).

Restoring hidden tabs before visible ones doesn't make sense as the user won't see the page anyway -- it won't even show in the tab strip!
blocking2.0? because this is technically a regression (caught in review, but it was considered minor enough to expedite the landing of tab candy).
blocking2.0: --- → ?
blocking2.0: ? → final+
I think we'll want to pull this back into a Beta, actually.
blocking2.0: final+ → betaN+
Blocks: 586068
blocking2.0: betaN+ → beta5+
(Assignee)

Comment 3

7 years ago
zpao, should this be assigned to you? If it being unassigned isn't a mistake, then I'll yoink it.
Nope I'm not taking this, but you can. It has a lot of overlap with bug 588217 and bug 586068 though. Probably best to get the quick fix in and just update patches in those other bugs if need be.
Assignee: nobody → dwitte
Status: NEW → ASSIGNED
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
Status: ASSIGNED → NEW
OS: All → Mac OS X
Hardware: All → x86
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 5

7 years ago
Created attachment 469657 [details] [diff] [review]
patch

Piece of cake.
Attachment #469657 - Flags: review?(paul)
Comment on attachment 469657 [details] [diff] [review]
patch

thanks dr. witte!
Attachment #469657 - Flags: review?(paul) → review+
(Assignee)

Comment 7

7 years ago
http://hg.mozilla.org/mozilla-central/rev/118b011d4d52
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 8

7 years ago
Verified fixed 

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100827 Firefox/4.0b5pre

I opened a bunch of tabs where the visible ones take a long time to load while the hidden ones take a very short time to load.  I waited about 10 seconds and while the two slow loading visible ones were still loading I scrolled down the tabbar and witnesses the fast loading hidden ones were still loading (most likely just started because they finished very quickly).
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 4.0b5
You need to log in before you can comment on or make changes to this bug.