"Next" used to take you directly to the next unread message in <= v2.

RESOLVED DUPLICATE of bug 545218

Status

Thunderbird
General
--
minor
RESOLVED DUPLICATE of bug 545218
8 years ago
6 years ago

People

(Reporter: William Babb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2

I haven't seen V2 for a while but I recall the "Next" button used to go to the next unread message without stopping even if it was in a different folder. This has not worked as in V2 and earlier since V3 came out. "Next" only exits the current message and must be repeated to get to the next unread message in another folder. Even then the message found must be double-clicked (or equivalent) to be opened. At best this is a nuisance. 

Reproducible: Always

Steps to Reproduce:
1.Open the last message in a folder
2.Click "Next"
3.TB closes the current message and remains in that folder.
4.Click "Next" again.
5.TB goes to next unread message in another folder but doesn't open it.
6.Press "Enter" or double-click to open new message.
Actual Results:  
Unread message is opened normally.

Expected Results:  
Clicking the "Next" button should have gone directly to the next unread message.

This occurs on the final message in a given folder where the next unread message is in a different folder.

Comment 1

8 years ago
What is the setting of "mailnews.nav_crosses_folders" ?  Default is "1" (ask), but it sounds like you have it set to either "0" (Cross without asking). or "2" (Stay in current).  If you've got it set to "0", it SHOULD go to the next folder, but it may not because of Bug 545218.  Can you check your symptoms agains those in that bug (modifying "mailnews.nav_crosses_folders", if necessary) to see if this bug is a duplicate of that one ?
(Reporter)

Comment 2

8 years ago
"mailnews.nav_crosses_folders" was set to "1". I've set it to "0." Restarting TB I find things haven't changed. I finish a folder, hit "Next" and it closes the tab and leaves me in the same folder. If I click "Next" again it takes me to a new folder but no farther, just like before. Checking "mailnews.nav_crosses_folders" and it's set to "0" as expected.

If this is a javascript problem I should tell you that the recent update of Firefox to Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729) seemed to help performance but apparently broke something related to javascript. I'm seeing symptoms like I had earlier this year where some video plays and some doesn't, I get an occasional message about run_active.js and some pictures don't display. It would probably explain some other anomalies, also.

Comment 3

8 years ago
I don't think this is a JS problem (but what do I know?).  

I'm surprised you didn't get prompted to cross folders with "mailnews.nav_crosses_folders" set to 1.  I only surmised you might have had it set to "0" because you weren't seeing the prompt; since you already had it set to "1" ("ask"), you SHOULD have been seeing the symptoms reported in Bug 545218 (the prompt and your clicking "Yes" should have occurred between steps 2 & 3 in the description).  Your repeat test with "mailnews.nav_crosses_folders" set to "0" produced the results I'd expect.

The question is, why don't you see the prompt when "N" would cross folders and "mailnews.nav_crosses_folders" is set to "1" ?  As far as I know, that's the only preference that would control the "crossing" behavior.
(Reporter)

Comment 4

8 years ago
"Error: An error occurred executing the button_next command: TypeError: aParent is null
Source File: chrome://global/content/globalOverlay.js
Line: 100"

The above error seems to correlate with my use of the "Next" button AFTER I set "mailnews.nav_crosses_folders" to "0." Prior to that change there was an error at a different location: 
"Error: this.search is null
Source File: file:///C:/Program%20Files/ThunderBird%203-0/modules/dbViewWrapper.js
Line: 756"

However, upon closer study, both errors may be after the change because I restarted TB and the error log probably was reset, no? I can't tell why the error changed when the operation was the same. Strange...!
(Reporter)

Comment 5

8 years ago
I did see the prompt if you mean the little dialog box that says something like "Do you want to advance to the next unread message." That was before the change. Now I no longer see it.

Comment 6

8 years ago
The error on line 756 is with the option set to "1" (ask).  Your experience with the option set to "0" is to be expected. It may occur at a different line in a different module, and you won't see the prompt, but I'm positive the cause is the same.  

Since you do have same experience (i.e., add the "missing two steps" in the description -- prompt and "Yes"), I'd say you're experiencing a duplicate of Bug 545218; I'll go ahead and DUP this bug report to that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545218
You need to log in before you can comment on or make changes to this bug.