Seamonkey nightly doesn't follow redirects

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: vvduma, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) Gecko/20100810 SeaMonkey/2.1a3pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) Gecko/20100810 SeaMonkey/2.1a3pre

Since the yesterday's update, Seamonkey doesn't automatically follows the redirect on the pages that send HTTP 301 as response.

Reproducible: Always

Steps to Reproduce:
1. With the latest nightly, enter http://gmx.de into the location bar
2. The HTTP response is 301 (moved permanently to http://www.gmx.net/)

Actual Results:  
The blank page is displayed.

Expected Results:  
The contents of http://www.gmx.net/ should have been displayed instead.
(Reporter)

Comment 1

8 years ago
Sometimes, instead of a blank page, the redirect page is displayed:

Moved Permanently
The document has moved here (link to http://www.gmx.net/).
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Comment 2

8 years ago
This can be reproduced using bugzilla too. Simply type a bug number into the quicksearch field at the top or bottom of a bugzilla page and hit the search button, then the same thing happens as described by the reporter of this bug. I think it started the day before yesterday actually (9.8.2010).

Comment 3

8 years ago
It's known that AdBlock plus has problems with latest nightlies like You describing. If you have AdBlock or NoScript, try to disable them.

Comment 4

8 years ago
You're right, it's Adblock. Should have though of that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

8 years ago
Indeed, with Adblock+ disabled it works for me.
Sorry for the false alarm.

Comment 6

8 years ago
(In reply to comment #5)
> Indeed, with Adblock+ disabled it works for me.
> Sorry for the false alarm.

Try installing the newest AdBlock+ dev build, Vladislav.
The creator of AdBlock+ recently came back from his vacation and updated the extension to resolve the problem.  I have AdBlock+ 8/19 v1.3a dev build installed with SM 2.1a3 candidate build and the problem no longer happens.
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> Try installing the newest AdBlock+ dev build, Vladislav.

Thanks a lot, actually I am already using it.
[Sorry for bugspam.]
You need to log in before you can comment on or make changes to this bug.