[ACR Extension] Preferences option is enabled in context menu of extensions with no preferences

RESOLVED DUPLICATE of bug 575255

Status

--
minor
RESOLVED DUPLICATE of bug 575255
8 years ago
3 years ago

People

(Reporter: Wurblzap, Unassigned)

Tracking

ACR-0.*
ACR-0.6
x86
Windows XP

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

If an add-on does not allow to modify settings, no "settings" button is being displayed for it. That's good. Similarly, its context menu should have the settings entry greyed out, but hasn't.
Can you give an example where you are seeing this? It appears to be greyed out for my extensions.
(Reporter)

Comment 2

8 years ago
I'm seeing this for the Add-On Compatibility Reporter, and for the Feedback Add-On, for example.
Could you try disabling the add-on compatibility reporter and then restarting and see if the problem still exists?
(Reporter)

Comment 4

8 years ago
All right, good catch! With the Add-On Compatibility Reporter disabled, the entry is greyed out.
So, can this bug be moved to the offending add-on somehow?
Brian, this sounds pretty similar to bug 582440
Component: Add-ons Manager → Compatibility Tools
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → compatibility
Summary: If an add-on does not allow to modify settings, its context menu should have the settings entry greyed out → [ACR Extension] Preferences option is enabled in context menu of extensions with no preferences
Version: unspecified → ACR-0.*
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575255

Updated

8 years ago
Target Milestone: --- → ACR-0.6
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.