Crash [@QuickTimeMPEG@0x24220][@ QuickTimeMPEG@0x26c8c] NSFW

RESOLVED WORKSFORME

Status

Plugins Graveyard
QuickTime (Apple)
--
critical
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Details

(crash signature, URL)

(Reporter)

Description

8 years ago
1.9.1|1.9.2 ppc ( i no longer test trunk ppc)

0xffff8944
QuickTimeMPEG + 0x24220
QuickTimeMPEG + 0x24e14
QuickTimeMPEG + 0x32b4
libSystem.B.dylib + 0x430d0

1.9.1|1.9.2|2.0.0 intel32

0xffff07f7
QuickTimeMPEG + 0x26c8c
QuickTimeMPEG + 0x277ca
QuickTimeMPEG + 0x286e4
QuickTimeMPEG + 0x2b52
(Reporter)

Comment 1

7 years ago
update crash bugs to critical per guidelines.
Severity: normal → critical
(Assignee)

Updated

7 years ago
Crash Signature: [@QuickTimeMPEG@0x24220] [@ QuickTimeMPEG@0x26c8c]
(Reporter)

Comment 2

6 years ago
Win7 Beta QuickTime 7.7
bp-127868f4-e8a2-4f97-ad34-0f1ef2120303
[@ quicktime.qts@0x13a09 ] 

Mac OX X 10.5 QuickTime 7.7
Opt Beta/11 - No Crash
Opt Aurora/12 - No Crash
Opt Nightly/13 - No Crash


Mac OS X 10.5 Debug Beta/11 QuickTime 7.7

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x205cb248
[Switching to process 26431 thread 0xd113]
0xffff07ff in ?? ()
(gdb) bt
#0  0xffff07ff in ?? ()
#1  0x00000000 in ?? ()

Another time I got a shutdown crash

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0xffffffff
0x002187ef in pcache1PinPage (pPage=0x1f2fd07c) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:35698
35698	  pGroup = pCache->pGroup;
(gdb) info registers
eax            0xffffffff	-1
ecx            0x0	0
edx            0xee07e001	-301473791
ebx            0x2187d8	2197464
esp            0xbfffdb70	0xbfffdb70
ebp            0xbfffdb98	0xbfffdb98
esi            0x2	2
edi            0x6dbd1d6	115069398
eip            0x2187ef	0x2187ef <pcache1PinPage+35>
eflags         0x10202	66050
cs             0x17	23
ss             0x1f	31
ds             0x1f	31
es             0x1f	31
fs             0x0	0
gs             0x37	55
Current language:  auto; currently c
(gdb) bt
#0  0x002187ef in pcache1PinPage (pPage=0x1f2fd07c) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:35698
#1  0x00218b1e in pcache1TruncateUnsafe (pCache=dwarf2_read_address: Corrupted DWARF expression.
) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:35775
#2  0x00219740 in pcache1Truncate (p=0x2499bfa8, iLimit=1) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:36142
#3  0x00217d60 in sqlite3PcacheTruncate (pCache=0xfd14c0, pgno=0) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:35116
#4  0x00217db3 in sqlite3PcacheClear (pCache=0xfd14c0) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:35133
#5  0x0021c802 in pager_reset (pPager=0xfd1408) at /work/mozilla/builds/beta/mozilla/db/sqlite3/src/sqlite3.c:38457


Mac OS X 10.5 Debug Aurora/12 QuickTime 7.7

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x1fb6c000
[Switching to process 26403 thread 0xba13]
0xffff0bd1 in ?? ()
(gdb) bt
#0  0xffff0bd1 in ?? ()
#1  0x00000000 in ?? ()


Mac OS X 10.5 Debug Nightly/13 QuickTime 7.7

Once I got the shutdown crash as seen in Beta.
Once I got

rogram received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x23367248
[Switching to process 26453 thread 0xb313]
0xffff07ff in ?? ()
(gdb) bt
#0  0xffff07ff in ?? ()
#1  0x00000000 in ?? ()

Another time I got
Assertion failure: chunk->unused(), at /work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp:558

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000
[Switching to process 26358 thread 0x4403]
0x00018f69 in MOZ_Crash () at /work/mozilla/builds/nightly/mozilla/mfbt/Assertions.cpp:76
76	  *((volatile int *) NULL) = 123;  /* To continue from here in GDB: "return" then "continue". */
(gdb) bt
#0  0x00018f69 in MOZ_Crash () at /work/mozilla/builds/nightly/mozilla/mfbt/Assertions.cpp:76
#1  0x00018fd3 in MOZ_Assert (s=0x7ab88f9 "chunk->unused()", file=0x7ab81f0 "/work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp", ln=558) at /work/mozilla/builds/nightly/mozilla/mfbt/Assertions.cpp:88
#2  0x075af912 in js::gc::ChunkPool::expire (this=0x7900d0, rt=0x790000, releaseAll=false) at /work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp:558
#3  0x075b54bb in js::ExpireChunksAndArenas (rt=0x790000, shouldShrink=false) at /work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp:2627
#4  0x075b8b64 in js::GCHelperThread::doSweep (this=0x79288c) at /work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp:2882
#5  0x075b8c67 in js::GCHelperThread::threadLoop (this=0x79288c) at /work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp:2725
#6  0x075b8e45 in js::GCHelperThread::threadMain (arg=0x79288c) at /work/mozilla/builds/nightly/mozilla/js/src/jsgc.cpp:2704
#7  0x00086be5 in _pt_root (arg=0x1744a0) at /work/mozilla/builds/nightly/mozilla/nsprpub/pr/src/pthreads/ptthread.c:187
#8  0x92b6e055 in _pthread_start ()
#9  0x92b6df12 in thread_start ()
Crash Signature: [@QuickTimeMPEG@0x24220] [@ QuickTimeMPEG@0x26c8c] → [@ QuickTimeMPEG@0x24220 ] [@ QuickTimeMPEG@0x26c8c ] [@ quicktime.qts@0x13a09 ]
OS: Mac OS X → All
(Reporter)

Updated

6 years ago
Duplicate of this bug: 676550
bc: can we close this bug, not reproducible anymore and we have removed plugins anyway from bughunter ?
Flags: needinfo?(bob)
(Reporter)

Comment 5

2 years ago
Yeah, let's do it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bob)
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.