OS/2 Several characters are displayed as blank

VERIFIED FIXED

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
8 years ago

People

(Reporter: Koike Kazuhiko, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
0x8160, 0x8161, 0x817c in JIS/Shift_JIS/EUC-JP page are displayed as blank.

http://www.ingrid.org/java/i18n/unicode-sjis.html

1-81(cent sign), 1-82(pound sign), 2-44(not sign) of JIS X 0208 in UTF-8
page are also displayed as blank.

This problem was reported on Japanese Bugzilla.
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=382

Comment 1

18 years ago
This is OS/2 only problem, correct?
(Reporter)

Comment 2

18 years ago
I forgot to copy the URL of UTF-8 case.
http://www.ingrid.org/java/i18n/unicode-utf8.html

Win98 build can displaye these codes, except yen sign(bug 57462).

Comment 3

18 years ago
Reassign to mkaply@us.ibm.com, cc to erik.
Assignee: nhotta → mkaply
Summary: Several characters are displayed as blank → OS/2 Several characters are displayed as blank

Comment 4

18 years ago
setting bug status to New.  kazhik, I've updated your bugzilla permissions.  
Please email me if you have any questions.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Changed QA contact to kazhik@mozilla.gr.jp since we do not support OS/2.
QA Contact: teruko → kazhik
(Assignee)

Comment 6

17 years ago
Created attachment 42911 [details] [diff] [review]
Basic UTF8 support in OS/2 - requires Times New Roman MT 30 - S-JIS still won't work

Comment 7

17 years ago
Following stuff may be useful to this bug.

mkjpconv.pl and usage:
http://bugzilla.mozilla.org/show_bug.cgi?id=54135

IBM943 conversion table (to give to mkjpconv.pl instead of CP932.TXT):
http://bugzilla.mozilla.gr.jp/showattachment.cgi?attach_id=259
(attached to http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=868 )

Comment 8

17 years ago
In OS2 VAC build(Build ID: 2001062912),
1-81(cent sign), 1-82(pound sign), 2-44(not sign) of JIS X 0208 in UTF-8 are displayed exactly.

IBM943 table above is created from 03AF34B0.TPMAP120 distributed by IBM DeveloperToolbox.
     http://service2.boulder.ibm.com/devcon/devcon/docs/nlstbl.htm
I can not find IBM-932 table, but IBM943 is very similar to IBM932.
#if IBM932 table is available, please use it.
(Assignee)

Comment 9

17 years ago
I have checked in our best attempt at UTF-8 on OS/2.

It has some limitations, but we have talked to the experts and this is the best 
we can do with what OS/2 has.

pages with a utf-8 charset will display correctly, but upper byte unicode chars 
will not display on other pages.

For instance, you can't display Chinese on a German web page using &xxx; values 
- it has to be a utf-8 page.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
#58637 reports two bugs.

First bug(sjis/euc/iso-2022-jp conversion table problem) is not fixed.
But I think that this is a duplicate bug(#54135).

And second bug(UTF-8 problem) is fixed.
(Assignee)

Comment 11

16 years ago
marking verified per reporters comments.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Depends on: 586423

Updated

8 years ago
No longer depends on: 586423
You need to log in before you can comment on or make changes to this bug.