4b4pre update - Spellcheck as you type is enabled, but not working.

RESOLVED FIXED in mozilla2.0

Status

()

--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: johnlgalt, Assigned: masayuki)

Tracking

({regression})

Trunk
mozilla2.0
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 beta4+)

Details

(Whiteboard: [fixed by backout of bug 581576], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100811 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100811 Minefield/4.0b4pre

Today's update to Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100811 Minefield/4.0b4pre appears to ahve broken spell checking.

While the option for automatically checking spelling as I type is enabled, when I am entering text into a forum where it has worked for the last *year* it is not working unless I maually enalbe it - and I have to manually enable ti for each post I make now.  It was worknig just 2 hours ago, prior to me updating minefield.

Reproducible: Always

Steps to Reproduce:
1.  Update to Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100811 Minefield/4.0b4pre
2.  Verify that Options --> Advanced --> General --> Check my spelling as I type is enabled
3.  Attempt to type into any text box (***EVEN THIS ONE***) and spell checking is not enabled, until you manually enable it in the context menu
Actual Results:  
Any text box that I type in spell checking is disabled until I manually enable it via the context menu.  It is happening on a per item level, meaning if I have to type i 3 different textboxes, I have to enable it three different times.

Expected Results:  
Spell checking should be enabled by default on all textboxes per the options menu setting.

As I mentioned, this just started with this latest build.
(Reporter)

Comment 1

8 years ago
I double checked to make sure it was not my profile by creating a brand new profile as well.

Also, since it was happening right here as I was typing the bug out (as is evidenced by my original description, which is not spell-checked) I think this is a build specific issue that should (hopefully) go away with the next build).

Comment 2

8 years ago
Regression window pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0c581111e40b&tochange=ba956b17d834
Candidate bug:
Bug 581576 - hung up or too slow when press Enter key on Gmail editor which has a lot of misspelled words
Blocks: 581576
Status: UNCONFIRMED → NEW
Component: Preferences → Editor
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: preferences → editor
Target Milestone: --- → mozilla2.0
Version: unspecified → Trunk

Comment 3

8 years ago
The problem happens on Linux build too.
Mozilla/5.0 (X11; Linux i686; rv:2.0b4pre) Gecko/20100811 Minefield/4.0b4pre ID:20100811025811
OS: Windows 7 → All
Hardware: x86_64 → All
Assignee: nobody → masayuki
blocking2.0: --- → beta4+
Duplicate of this bug: 586496
Duplicate of this bug: 586504
The patches was backed out already.

Updated

8 years ago
Duplicate of this bug: 586608

Comment 8

8 years ago
Fixed by backout of bug 581576.

http://hg.mozilla.org/mozilla-central/rev/63cd1b376c83
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by backout of bug 581576]
You need to log in before you can comment on or make changes to this bug.