font-weight: bold; effect stacking with descendant strong/b tags

RESOLVED DUPLICATE of bug 589124

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 589124
8 years ago
7 years ago

People

(Reporter: Jason M, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.0; WOW64; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.0; WOW64; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

The latest update to Gmail brought my attention to a bug with a very specific context:
If a strong or b element is nested within an element whose font-weight is set to bold, the bolding effect stacks -- but only if the font is Arial.

Reproducible: Always

Steps to Reproduce:
1. Sign into Gmail.
2. Look at the "Archive" button.
3. Use Firebug to toggle the font-weight property, and watch the text expand/contract.
Actual Results:  
The text is bolded twice.

Expected Results:  
Bold font-weight and strong/b are redundant; their effects should not stack.
(Reporter)

Comment 1

8 years ago
Created attachment 464951 [details]
example of double and normal bolding

Comment 2

7 years ago
Created attachment 502265 [details]
Nested 'strong' display Fx4 vs. Chrome10

Another example of this: http://www.guardian.co.uk/money/2011/jan/08/self-build-dream-home - see the 'Finding finance' H2 after the fifth paragraph. It's coded as:

<h2> <strong>Finding finance</strong> </h2>

Chrome 10 and Opera 11 both display it as 'normal' strong. Fx4 and IE9 display it as 'extra' strong. See screen grab.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589124
You need to log in before you can comment on or make changes to this bug.