Closed Bug 586488 Opened 10 years ago Closed 10 years ago

Automatic message filter doesn't work on Inbox with many mailboxes

Categories

(MailNews Core :: Filters, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 34973

People

(Reporter: martin.strejc, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox/3.6.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100720 Fedora/3.1.1-1.fc13 Lightning/1.0b2pre Thunderbird/3.1.1

Mail is not filtered by message filter(s) when a new mail comes (automatic filter), even filter(s) work when I manually run the filter from menu on any folder including grouped inbox folder. It means the general inbox grouped by inbox of few mailboxes (function since TB 3.0). When any of simple inbox of mailbox (e.g. inbox just of mymail@mydomain.com) is clicked and a new comes, the filter seems to work correctly.

Reproducible: Sometimes

Steps to Reproduce:
1. Make several mailbox connections (try combine both of POP3 & IMAP accesses)
2. Make one or few mailfilters (sorting mails by sender into different folder, e.g. from bugzilla to folder BUGZILA, from facebookmail.com to folder FB)
3. Click the main Inbox folder and see all incoming mails of all mailboxes
4. Wait until new mail comes
Actual Results:  
The new mail holds in the inbox folder.

Expected Results:  
Mail is moved into specified folder as well as message filter is set to.

I haven't catch if the same problem occurs in TB on MS Windows XP (I used before)
First time I caught that problem was after adding a new filter (I had been having 5 filters, I've added 6th)
Anything in Tools -> Error console when this happens ?

Have you tried to start thunderbird in safemode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode) ?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Error console hasn't any message (no error, no warning).

I haven't used to start TB in safe mode, everything goes well just except the case of msg filtering. I do not have any special pluging except thundrbird-lightning (calendar). 

Of course I can try safe mode.

My new note is: When the general inbox folder is clicked, the menu item Run filter on folder is going to be disabled. Even though it has no logic, because filter rules are defined for each mailbox and they can be run on the general inbox folder as well as on other folders.

That should probably be a reason of this bug. If DISABLE flag (probably a boolean property or function in code) is set, incoming mails are not filtered because this FLAG is tested and its value is used not only for menu also for incoming mail function to decide if use or not use filter rules.

Probably I should see the source code, however I guess that it will be faster when any of authors is going to do.

Also anybody can give me and advice when to find in source.

I guess the solution should be in enabling filters on folder for the general inbox.
"filter rules are defined for each mailbox and they can be run on the general
inbox folder as well as on other folders"

Filters are defined per account, not per folder and not globally. Since the "general inbox folder" spans multiple accounts, for filters to work on all inboxes, they would need to be defined on all accounts. You did not make it clear in your descriptions that you understand this. So I would disagree that "filters can be run on the general inbox folder".

In your STR you say "Make one or few mailfilters ... " but you don't specify where you are creating them, and that is very important.

I suspect that what you really want is a global filter, and that is bug 34793.
Yeah, I see. It is a problem of cross-requirements.

The final effect is:

I.Global filters work on global inbox folder

II.Filters for mailbox work on given mailboxes

When a new mail come the TB decision if use or not use filter splits into two way dependent on I. or II. The decision is made by the folder, which is "active" (it means you click on and see the folder content)

The result is:
1. (it is correct) If you are in any other folder than global inbox and a new mail is coming, each global or mailbox filter is correctly applied. 

2. (probably incorrect) If you are just in global inbox and a new mail is coming, only global filters are applied, other filters are ignored.

My opinion is that the 2. is incorrect because the consequence is that TB  automatic filters are dependent on cursor (or active window) position. I guess it is not the most logical functionality.

Probably it needn't be a bug however it could be a task or new requirement.
I'm confused whether comment 4 was supposed to describe how you think things are, or how you think they should be. You continue to use the term "global filters" when such things do not exist (the closest thing is when you use Local Folders as a deferred-to (or Global) inbox, then those filters will also get applied.) But I think when you are using the term "global inbox", you are referring to the Smart/Unified Inbox which is different.

I would like to see some resolution of this bug. If what you really want is a global filter, or to discuss how that might be implemented, the correct thing to do is to dup this to bug 34973 (not 34793 as I mistyped earlier) and continue the discussions there.
Yes, it is a part of funcionality logic, not bug. I rather continue bug 34973 instead. Thanks ;-)
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
WONTFIX is reserved for drivers normally. I'm going to dup to 34973 instead. If that does not make sense, perhaps INVALID is another choice.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: GlobalFilters
You need to log in before you can comment on or make changes to this bug.