Bad table reflow (different layout each reload)

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: odd@findus.dhs.org, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test9 i686; en-US; m18) Gecko/20001031
BuildID:    2000103106

Mozilla fails to render the table in the section "Galleri" correctly at the
first load. Other browsers (NS 4.75, IE 5.5 renders it correctly).

Reproducible: Always
Steps to Reproduce:
1.Load http://iesbild.com/ - Works fine
2.Click "Galleri" - thumbnails rendered incorrectly
3.Click the flower (or wherever, just load a new page in the site)
4.Click "Galleri" again - the table layout is correct

Actual Results:
On 1, -
On 2, Table layout is INCORRECT
On 3, -
on 4, Table layout is CORRECT

Expected Results:  Mozilla should have rendered the table layout in "Galleri"
correctly on the first try.

Comment 1

18 years ago
This is even worse than it looks at first glance, I think. Hitting reload, I've
been able to force Moz to recreate the table randomly- it is different from the
previous reload something like 50% of the time. Pictures get merged, and it
appears that order is changed at least some of the time. Don't know if this is a
JS or table problem, but it is pretty nasty. #mozillazine confirms it on Linux
and but no problems with win32. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

18 years ago
As timeless on IRC/#Mozilla requested, here are screenshots:

Netscape 4.75: http://findus.dhs.org/~odd/mozbugs/iesbild.com_netscape475.png
Mozilla 2000103106 1st try:
http://findus.dhs.org/~odd/mozbugs/iesbild.com_mozilla2000103106_first.png
Mozilla 2000103106 2nd try:
http://findus.dhs.org/~odd/mozbugs/iesbild.com_mozilla2000103106_first.png
(Reporter)

Comment 3

18 years ago
Erratum:

Mozilla 2000103106 2nd try:
http://findus.dhs.org/~odd/mozbugs/iesbild.com_mozilla2000103106_second.png
I am seeing this on NT branch build 2000-10-31-14 as well. OS -> All.

Over to HTMLTables.
Assignee: clayton → karnaze
Component: Layout → HTMLTables
OS: Linux → All
QA Contact: petersen → chrisd

Comment 5

18 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001012205
Marking as such.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Did NOT work in the Jan 22 Linux build I tried.

Hrmph.
(Reporter)

Comment 7

18 years ago
Can someone PLEASE show me a screenshot where this renders correctly THE FIRST
TIME?!
Reopening.  I tried this with the 2001-02-12-08 Linux build and I see the exact
problem described.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

17 years ago
Well, hm. I've been told that it's my faulty, non-standards HTML/CSS that is to
blame?

Now, I'm not good at all at coding standards-compliant HTML/CSS, so perhaps
someone could take the code and correct it and see if that may help the
rendering... though I doubt that'd help... the table is pretty much correct, no?
OK.  I have an HTML4.01-compliant version of this page.  I still see the bug
with this page and the 2001-02-14-08 build.  Going to attach the page here.

Changes I've made from the original:

1) Removed the external stylesheet (to simplify things)
2) added a <base> tag so that it will find the images correctly.
3) Removed the style from <a> from the inline stylesheet (again, to simplify things)
4) Added inline style to put borders around <td> elements (blue for outer table,
red for inner tables) so we can see how they are being laid out.
5) Added an inline style to put borders around the inner <table> elements (green
border)

Here is what I see:  the <td> elements of the inner tables are overflowing their
tables.  Looks like the page is not correctly reflowed as the images are loaded.
 Setting width and height on each image explicitly may fix the problems we are
seeing here, but Mozilla should still get this right.
Created attachment 25282 [details]
HTML4.01-compliant version of page
(Reporter)

Comment 12

17 years ago
All praise Boris Zbarsky! :)
Going to attach a fairly minimal testcase.  To reproduce with it, just load it
and hit the reload button a few times....  Maybe shift-reload if just reload
does not do it for you, but I have found that unnecessary.
Created attachment 25285 [details]
Testcase.  green border for table, red for <td>
(Reporter)

Comment 15

17 years ago
After the first load, when it is layed out incorrectly, I have to mark the URL
location bar and press enter for it to render correctly -- shift reload doesn't
do any difference on this machine (build 2001021409).

Comment 16

17 years ago
I can confirm using the last testcase on 0.8 branch build, win95. The red border
extends further to the right than the green border.

Comment 17

17 years ago
For more fun (at least on Linux), try dragging another window over the right end
of the table, either slowly or quickly for interesting redrawing effects.
Bug only occurs for Linux - adding keyword pp, OS -> Linux.
Bug occurs in build 2001-02-26-11 on Linux/Debian
Bug does NOT occur in build 2001-02-26-05 on Windows NT4 sp6
Bug does NOT occur in build 2001-02-23-11 on Windows 98 SE
Keywords: pp, testcase
OS: All → Linux

Comment 19

17 years ago
I retried this on build 2001022605 on windows 95. When first opening the
testcase, it displays correctly. Then everytime I reload I get a new layout,
images cut in half, borders extending to the right, etc.
Updating summary
Keywords: pp
OS: Linux → All
Summary: Bad table rendering; when reloaded, layout is correct → Bad table reflow (different layout each reload)
(Reporter)

Comment 20

17 years ago
Buhuu buhuu.

Not to spam, but I really want this fixed (if it in fact is a problem).
(Assignee)

Comment 21

17 years ago
chrisd, can you see if this is still a problem on Linux. I can't reproduce it on 
WinNT.

Comment 22

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 23

17 years ago
Still a problem on Linux, latest CVS build.
works correctly for me now, linux build 2001-03-23-08
(Reporter)

Comment 25

17 years ago
It seems fixed here too.

Marking as such, okay?
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 26

17 years ago
Reopening to change the status.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 27

17 years ago
A bug is usually marked fixed when there is a patch attached or it can be 
explained by some other patch (and it is not a dup). Marking worksforme.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 28

17 years ago
 Verified works for me..
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.