redirect to same page after POST sends you to redirect_loop.xul

VERIFIED DUPLICATE of bug 44153

Status

()

Core
Networking: HTTP
P3
normal
VERIFIED DUPLICATE of bug 44153
17 years ago
17 years ago

People

(Reporter: matthewb, Assigned: Darin Fisher)

Tracking

({verifyme})

Trunk
mozilla0.8
x86
All
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If I post to a page e.g. redirect.view, which redirects back to itself, I end 
up on redirect_loop.xul.

The redirect loop detection does not handle this reasonable case.  The reason 
for the redirect (rather than returning the information directly) is to avoid 
warnings about reposting information if the user tries to refresh the page.

cf. nsHTTPChannel::Redirect()

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 1

17 years ago
Yup. This is related to bug 40080, but because the status of that bug is
unclear, I won't mark it as a dup. It is also related to 44153, which seems to
indicate that there is some "brokenness" in redirect.xul but doesn't say what it
is. Confirming, but I don't know what (if anything) will happen to it.
(Assignee)

Updated

17 years ago
Blocks: 61693

Comment 2

17 years ago
*** Bug 62242 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

17 years ago
->me
Assignee: gagan → darin
Component: Networking → Networking: HTTP
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 44153 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
qa to me.
+verifyme
I'm using the URL field test case, but not clear on what should happen.

Clicking on the button in Mozilla does not produce errors or other strageness. 

But clicking on it in Communicator returns a "Document contains no data" error.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: tever → benc
(Assignee)

Comment 6

17 years ago
redirect_loop.xul is never loaded now-a-days.
You need to log in before you can comment on or make changes to this bug.