Some redirects fail resulting in white screens or "302 Found" or similar

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
8 years ago
4 years ago

People

(Reporter: Michael Marley, Unassigned)

Tracking

4.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b4pre) Gecko/20100812 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b4pre) Gecko/20100812 Minefield/4.0b4pre

Ever since about a week ago (sorry, I don't remember exactly when), some types of redirects haven't been working properly in the Firefox 4.0 nightlies.  Sometimes these failed redirects result in WSoDs and sometimes they result in HTTP "Moved" or "Found" pages with links to the correct content.  One type of redirect that I know fails is the HTTP Location header.  I have not been able to figure out what other types of redirects cause the problem, however.  One example of a site that will not work at all due to the error is "http://phpmyadmin.net"  I have also reproduced this bug using an x86 build on another Win7 machine.

Reproducible: Always

Steps to Reproduce:
1.Access a website that uses certain redirects, including HTTP location headers
2.
3.
Actual Results:  
A white screen of death or an HTTP status message is produced.

Expected Results:  
The website loads properly

Comment 1

8 years ago
I can confirm this as well.

For example:
http://google.ca/ redirects to http://www.google.ca/ but instead, I see a 301 Moved page. Wikipedia displays a "Moved Permanently" page, etc.

Comment 2

8 years ago
Confirming on build Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b4pre) Gecko/20100812 Minefield/4.0b4pre

I get it every three or four pages, mostly with google results (google tracker redirecting)...

I think this has been introduced last weekend, it worked before that. Maybe around 20100807?

Comment 3

8 years ago
Sorry I should have added this: 
Reproduced on both Windows Seven and Apple Leopard 10.5.8
Try a new profile without add ons. There are many recent redirect bugs filed and they have all turned out to be down to a code change causing add ons to break redirection.

Comment 5

8 years ago
Thanks, 
Looks like Firebug is causing it. I currently have 1.6X.0a19
(Reporter)

Comment 6

8 years ago
Sorry.  In my case, it is Adblock Plus causing the problem.

Comment 7

8 years ago
Adblock is off on both my machines at the moment...
So maybe there are several addons that are causing this.

Comment 8

8 years ago
I had the same problem. After I disabled Adblock Plus (adblockplus-1.3a.20100726.xpi), it worked again.

I also have Firebug 1.6X.0a19 installed. That doesn't seem to play a role, as far as I could observe.

Looks like this is affecting all OS.

Comment 9

8 years ago
Seems the problem has been fixed. Anyone continuing to experience these problems should update their add-ons.

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.