If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Compacting Causes a few problems

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
7 years ago
5 years ago

People

(Reporter: Michelle, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: 3.0.6

Ok, this has happened several times & I see other people have issues with the compacting too, but not exactly what I'm experiencing.

Reproducible: Always

Steps to Reproduce:
1. If I have any e-mails in writing mode, meaning they haven't been sent yet, there are issues.
2. After it compacts, that open e-mail won't save. TB says it's unable to save it.
3. If I try to send it, the e-mail in the inbox doesn't show the icon that it's been sent.
4. If a search window is open, it won't let me search e-mails. It just shows very weird empty fields OR, if there was data in the fields before the compacting, it deletes part of the data & I can't use that search window anymore, I have to close it down & open a new one.
5. Also I really have no idea how often the compacting is supposed to occur as I put it on automatic & it sometimes wants to compact 3-5 times in one hour which I find excessive.

We tried to troubleshoot problems I may be having with TB & that slowed down the compact popup somewhat, but it still asks me to compact way more than I think it should & yes I do have a lot of e-mails.
6. I never know what folder it's compacting. At first I thought it was only the account I was in before it started, but then it would tell me that it was compacting the inbox, then something else, then the inbox again.

I was told on the forum that it compacts all the inboxes in all my accounts, but that seems unlikely. It's not clearly telling me which inbox it's compacting & sometimes it doesn't tell me what it's doing at all.
Actual Results:  
I can't compact when I'm here as it's clear that when I use TB while it's compacting, it does damage to TB or my e-mails.

If it was fast it would be ok, but sometimes the compacting can last 2-4 minutes although I haven't timed it.


Expected Results:  
That it will compact without damaging anything, that it will tell me exactly what folders it's compacting & I understand why it's trying to compact so many times per hour.

see above. I hope I explained things clearly. I may have to add more info right after it happens. I'm going by memory.

Thanks


Michelle
Meta Bug 498274 is a collection of phenomena around "Compact Folder(s)". See all bugs listed in Dependency Tree for Bug 498274. Do you see already reported problem(s)?
Read Bug 498274 Comment #2 and enable dialog before auto-copact, and check whether auto-compact is really executed when you see your problems, please.
And, keep "one problem per a bug", please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498274
> Status: RESOLVED DUPLICATE of bug 498274

Why can bug for specific problem be a dup of meta bug for tracking purpose?
Reopein.

> 2. After it compacts, that open e-mail won't save. TB says it's unable to save it.
> 3. If I try to send it, the e-mail in the inbox doesn't show the icon that it's been sent.

Bug opener, did you compose HTML mail with embed image? (It sounds so)
If yes, you perhaps saw a phenomenon stated in bug 532395 comment #42.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

5 years ago
While I can't remember b/c it's been such a long time, I highly doubt the e-mails had images embedded in it. In fact I have to hazard a guess that none of them did as I normally send e-mails with images right out.

I'm sorry, I tried to read comment 42 7 it's just a mess. I can't figure out what it's saying, what is pasted from before, what's the comment from you alone, etc.
IIRC, bug relevant to your request 6 exists, which is request like "show progress of Compact in Activity Manager panel". Because "one problem per a bug" is rule at bugzilla.mozilla.org(here is not support forum/help center. here is place to report Tb's flaw in code to developer or request enhancement of Tb to developer), it's hard to procces all of your problem reports and enhancement request in single bug at B.M.O.
If you still see each problem and if some enhancements is still needed for you, open separate bug for each problem/request, please.

Closing as INCOMPLETE.
If you don't see your problems in recent b release, close as WORKSFORME("resolved by unknown patch" at B.M.O), please.
If closing is wrong, re-open, please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

5 years ago
I'm sorry I'm still having problems understanding what you are saying.

I didn't lump 6 issues into one. This was about the compacting issues & it's still a problem. So I really don't understand why you think I came on here for support. I came on here to file a bug report & I did. 


Michelle
(Reporter)

Comment 7

5 years ago
This is not resolved. In fact I just had this compacting issue the other day.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
There are four kinds of issue in this bug.
(Type-A) 1, 2, 3 : problem in mail composition after Compact
                   It looks same as your bug 795207, I'm not sure though.
(Type-B) 4 : problem in search window after Compact.
             bug report for funny behaviour at search result window exists.
(Type-C) 5 : detailed description of auto-compact's spec is needed at somewhere.
             You might have seen problem like bug 750569, bug 762169, bug 755993,
             and bug 785777.
(Type-D) 6 : status display of Comact is needed at somewhere.
             "progress meter like one at Activity Manager" is an example.
These are better processed in separate bug.

Updated

5 years ago
Blocks: 498274

Comment 9

5 years ago
(In reply to Michelle from comment #7)
> This is not resolved. In fact I just had this compacting issue the other day.

Hi Michelle, you are certainly right that there are issues around compacting that are unresolved. There is no doubt about that. However, perspectives on these issues are different from a developer and end user perspective. Maybe for you as an end user, it looks more like a single issue of "compacting breaks a lot of things" (which is true). For developers, they need to find out all the details: *why exactly* does compacting break a), and why does it break b), and is it really responsible for c) or perhaps there is another cause besides compacting. Until such time that all the processes are fully understood (which they are /not/ at present), developers will always assume that a) b) and c) are separate issues that need their own bug for close scrutiny. It's also possible that a) b) and c) break due to different aspects of compacting. Again, that would require separate bugs, even though all of them are somehow about "bugs in compacting".

In that developer perspective, I agree with WADA's comment 8 that:
- This bug report seems to cover more than one problem
- All sub-problems of this bug report seem to be covered by other existing bugs

Add to that the other problem that TB is understaffed, and Mozilla is withdrawing full-time staff from the project, and realize we'll probably have to live with these problems for quite a while. We have end user reports for almost anything, but it's a huge number of bugs and the progress on them is rather slow.

We do appreciate the time you take to file these issues, as well as the inconveniences caused by them. For the sake of tracking and acting on these bugs, we have no choice but taking the developer perspective and dissecting them until they are ready for consumption (if there's anybody present, able and willing to do so). In fact, few and specific bugs about a clearly defined issue usually have bigger chances of getting fixed than "one-for-all" type of bugs (notwithstanding that sometimes the big perspective of "compacting is broken" might also help to realize the need for action). And less open bugs also means it will be easier to find the relevant ones.

So I'd think it will be in your own interest if we close this bug (as incomplete) and hope for those more specific bugs that cover your problems to get some attention.

Comment 10

5 years ago
(In reply to WADA from comment #8)

> (Type-D) 6 : status display of Comact is needed at somewhere.
>              "progress meter like one at Activity Manager" is an example.
> These are better processed in separate bug.

I think for Michelle's purposes, she just wanted
Bug 689992 - When compacting, also display account name in status bar.
So #6 is also covered.

(Otherwise, total progress of compacting, or entries in activitiy manager would need separate bugs if we don't have them yet).
(Reporter)

Comment 11

5 years ago
Hi Thomas,

Sorry for the delay.

Oh I didn't know things aren't going well there staff wise. Sorry to hear that.

Unfortunately b/c I'm not a developer, I don't know how to break things up into little pieces. I can only relate what is happening.

If you can break it up for me, that would be much appreciated. I just don't want anyone to forget about this.

Thank you


Michelle

Comment 12

5 years ago
(In reply to Michelle from comment #11)
> Hi Thomas, [...]
> Unfortunately b/c I'm not a developer, I don't know how to break things up
> into little pieces. I can only relate what is happening.

Fair enough. But unfortunately b/c of the technical nature of such problems, they can only be addressed after breaking them up, and ideally bugzilla.mozilla.org (short bmo) is only for those technical one-issue-per-bug reports.

Michelle, a better alternative for bug reports where you just "relate what's happening" might be TB's support platform:
https://getsatisfaction.com/mozilla_messaging/
Ideally, there will be more people who can assist with working around problems, and/or breaking problems up into useful parts and find out if they have already been filed in bmo. (I won't see your gs reports unless you send me an email with a pointer).

> If you can break it up for me, that would be much appreciated. I just don't
> want anyone to forget about this.

Rest assured that all of the problems you mentioned in your comment 0 are already covered by existing bug reports filed by others (as explained by Wada and me in comment 8, comment 9, and comment 10), so they won't be forgotten.

So we can safely close this bug without losing track of these issues.
Closing this bug will also spare you from more technical questions and research tasks...

(The choice of possible bug resolutions is limited, and "incomplete" seems best in the sense of what I explained above - no offence meant.)

> Thank you

Most welcome.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.