Last Comment Bug 586647 - The bookmarks dropdown button can be made visible in the menu bar, but not in the nav bar
: The bookmarks dropdown button can be made visible in the menu bar, but not in...
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 07:10 PDT by Marc Schumann [:Wurblzap]
Modified: 2011-09-11 03:31 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marc Schumann [:Wurblzap] 2010-08-12 07:10:53 PDT
Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

The bookmarks dropdown button (the one equivalent to the bookmarks menu item) can be made visible in the menu bar, but not in the nav bar. Meaning, if I have the bookmarks toolbar turned off (which is a prerequisite for the button showing up at all, I understand), the bookmarks dropdown button is shown if I have it placed in the menu bar, but not if I have it placed in the nav bar.

1. Turn bookmarks toolbar off
2. Customize toolbars so that the bookmarks dropdown button is in the menu
   bar, to the right of the "Help" menu
3. Finish customizing
4. See the bookmarks dropdown button to the right of the "Help" menu
5. Customize toolbars so that the bookmarks dropdown button is in the nav
   bar, to the right of the address field
6. Finish customizing
7. See the bookmarks dropdown button vanish from the nav bar
Comment 1 Michael Lefevre 2010-08-31 11:24:01 PDT
I think this is intended. As you said, the button is equivalent to the menu item, so if you have the menu showing, then the button is redundant.

It is rather weird that you can customise the button onto the menu bar or other places, because it only does the automatic hiding when on the nav bar. That is probably bug 583749
Comment 2 Marc Schumann [:Wurblzap] 2011-09-11 03:31:00 PDT
This appears to have been taken care of in the meantime. It's working for me with 7.0.

Note You need to log in before you can comment on or make changes to this bug.