Release Windows MMGC settings are unoptimized

RESOLVED FIXED in Q3 11 - Serrano

Status

Tamarin
Build Config
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Werner Sharp, Assigned: Werner Sharp)

Tracking

unspecified
Q3 11 - Serrano
x86
Windows 7

Details

(Whiteboard: PACMAN)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Currently "Custom" Optimization and "Default" for inline function expansion is not inlining WB functions.   Switching to "Max speed" and "only __inline" significantly improves performance.  (player build config uses these settings already so this will only help the avmshell)
(Assignee)

Updated

8 years ago
Assignee: nobody → wsharp
Whiteboard: PACMAN
(Assignee)

Comment 1

8 years ago
Created attachment 465254 [details] [diff] [review]
fix release+release_debugger 32+64 bit configs

Switched four release configs to "maximum speed" and "only __inline" to match avmplus config settings and player settings.
Attachment #465254 - Flags: superreview?(edwsmith)
Attachment #465254 - Flags: review?(stejohns)

Comment 2

8 years ago
Comment on attachment 465254 [details] [diff] [review]
fix release+release_debugger 32+64 bit configs

looks ok to me, might also want to check the VS2010 project.
Attachment #465254 - Flags: superreview?(edwsmith) → superreview+

Comment 3

8 years ago
Any way that this could be applied to the x-platform build scripts?
(Assignee)

Comment 4

8 years ago
Created attachment 465266 [details] [diff] [review]
get 2010 working as well and fix flags
Attachment #465254 - Attachment is obsolete: true
Attachment #465266 - Flags: superreview?(edwsmith)
Attachment #465266 - Flags: review?(stejohns)
Attachment #465254 - Flags: review?(stejohns)
(Assignee)

Comment 5

8 years ago
x-platform build scripts look okay:

        if config.getDebug():
            DEBUG_CXXFLAGS = "-Od "
            DEBUG_CFLAGS = "-Od "
        else:
            OPT_CXXFLAGS = "-O2 -Ob1 -GR- "
            OPT_CFLAGS = "-O2 -Ob1 -GR- "

Comment 6

8 years ago
Comment on attachment 465266 [details] [diff] [review]
get 2010 working as well and fix flags

nothing obviously wrong
Attachment #465266 - Flags: superreview?(edwsmith) → superreview+

Updated

8 years ago
Attachment #465266 - Flags: review?(stejohns) → review+

Updated

8 years ago
Status: NEW → ASSIGNED

Updated

8 years ago
Target Milestone: --- → flash10.2
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/tamarin-redux/rev/99d39597c36c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.