Note: There are a few cases of duplicates in user autocompletion which are being worked on.

text-decorations are drawn through text areas

RESOLVED FIXED in mozilla8

Status

()

Core
Layout
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
mozilla8
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Bug 585684 has some of the details on this problem and an example at https://bugzilla.mozilla.org/attachment.cgi?id=465037
(Reporter)

Updated

7 years ago
Blocks: 585684

Comment 1

7 years ago
Note that this behavior is purposeful.  See http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/forms/nsTextControlFrame.cpp&rev=3.151#1589 (there's equvalent code in forms.css now) and the blame on revision 3.106 of nsTextControlFrame.cpp.

Updated

7 years ago
Summary: text-decoration is are drawn through text areas → text-decorations are drawn through text areas
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Note that this behavior is purposeful.  See
> http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/forms/nsTextControlFrame.cpp&rev=3.151#1589
> (there's equvalent code in forms.css now) and the blame on revision 3.106 of
> nsTextControlFrame.cpp.

Is this the behaviour we want? It doesn't really seem useful to have text-decoration drawn on a text area.

If it is what we want, than I suppose we should fix the reftest.

Comment 3

7 years ago
> Is this the behaviour we want? 

An excellent question.  I don't think it is, myself...
Depends on: 403524
I think this is fixed by
https://hg.mozilla.org/integration/mozilla-inbound/rev/c9dff8b867f0
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6912479afdd
and the other work in bug 403524.
(In reply to comment #4)
Confirmed concerning https://bugzilla.mozilla.org/attachment.cgi?id=465037 against Tinderbox Win32 Build http://hg.mozilla.org/integration/mozilla-inbound/rev/088a2d2cdf33 compared to yesterday's Nightly.
(Reporter)

Comment 6

6 years ago
Yep looks like it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Target Milestone: --- → mozilla8

Comment 7

6 years ago
Patch for bug 403524 makes the anonymous div inside textareas and inputs into  inline-blocks, thereby ignoring text-decorations defined outside the textarea itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.