Last Comment Bug 586818 - Renable test for chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul | Test timed out.
: Renable test for chrome://mochikit/content/a11y/accessible/test_name_nsRootAc...
Status: RESOLVED FIXED
[fixed by bug 719754] b4
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows XP
: P2 normal (vote)
: mozilla13
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
Depends on: 542726 633725 719754
Blocks: 574217
  Show dependency treegraph
 
Reported: 2010-08-12 16:27 PDT by Ed Lee :Mardak
Modified: 2012-02-06 13:31 PST (History)
9 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to disable test, v.1 [Checked in: Comment 7] (683 bytes, patch)
2010-08-12 16:30 PDT, Justin Dolske [:Dolske]
no flags Details | Diff | Splinter Review

Description Ed Lee :Mardak 2010-08-12 16:27:00 PDT
The test was disabled after bug 574217 landed due to timeouts and previous failures bug 525175 and bug 542726
Comment 1 Justin Dolske [:Dolske] 2010-08-12 16:30:36 PDT
Created attachment 465455 [details] [diff] [review]
Patch to disable test, v.1
[Checked in: Comment 7]

Disable the test on all platforms.
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-12 16:50:50 PDT
Any reason why we did see this failure when playing on maple?
Comment 3 Justin Dolske [:Dolske] 2010-08-12 17:10:55 PDT
More detail on the disabling:

Looks like this test has a history of timeouts (bug 525175 on Linux, and bug 542726 for SeaMonkey), though this seems to have gone perma-orange on Windows after TabCandy (bug 574217) landed.

The test itself looks a bit questionable...

test_name_nsRootAcc.xul is really just a stub for opening a new window containing name_nsRootAcc_wnd.xul, which is where the interesting parts of the test happen. It has a <tabbrowser> and <tabs>, and is simulating switching between to tabs in this window. The sketchy part is in switchTabSelectChecker(), where is seems to be constructing a fake event, and doTest() constructing some kind of event queue with it.

This all seems very odd to me, I'd expect just plain old tab eventListeners to detect tab selection changes at the right time, and that seems absent.

It's not entirely clear _exactly_ why this is failing -- did TabCandy cause a real behavioral change here, or just a timing change? The TabCandy and A11Y team should sort this out ASAP -- but given the history and inspection of the test I think it's reasonable to disable it while that investigation happens.

Log spew from an example failure:

From http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281651814.1281653094.18428.gz&fulltext=1#err4

11283 INFO TEST-START | chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul
11284 INFO TEST-INFO | chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul desired window: ([object Window]) chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul child window: ([object XPCNativeWrapper [object Window]]) chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul docshell visible: true
11285 INFO TEST-INFO | chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul | already focused
11286 INFO TEST-INFO | chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul desired window: ([object Window]) chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul child window: ([object XPCNativeWrapper [object Window]]) chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul docshell visible: true
11287 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul | Test timed out.
11288 INFO SimpleTest finished chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul in 318868ms
Comment 4 Justin Dolske [:Dolske] 2010-08-12 17:14:42 PDT
(In reply to comment #2)
> Any reason why we did see this failure when playing on maple?

Mardak says this was indeed orange on the maple runs, but was just somehow overlooked.
Comment 5 Dão Gottwald [:dao] 2010-08-12 23:37:39 PDT
Could this be related to the use of TabView in tabbrowser.xml? Has the if (TabView && TabView...) pattern actually been tested? Looks like it would fail with TabView not being defined.
Comment 6 Ian Gilman [:iangilman] 2010-08-13 11:35:45 PDT
(In reply to comment #5)
> Could this be related to the use of TabView in tabbrowser.xml? Has the if
> (TabView && TabView...) pattern actually been tested? Looks like it would fail
> with TabView not being defined.

I was thinking that too... shouldn't it be if (window.TabView && TabView...)?

I can make the change, but don't have a Windows dev environment to test in. Perhaps push to maple?
Comment 7 Serge Gautherie (:sgautherie) 2010-09-16 02:54:35 PDT
Comment on attachment 465455 [details] [diff] [review]
Patch to disable test, v.1
[Checked in: Comment 7]

http://hg.mozilla.org/mozilla-central/rev/dd73091a6315
Comment 8 Serge Gautherie (:sgautherie) 2010-09-16 02:57:08 PDT
Comment on attachment 465455 [details] [diff] [review]
Patch to disable test, v.1
[Checked in: Comment 7]

>+      // Actually, just disable this test everywhere -- bug 586818.

A |todo(false, ...)| would be better than a comment...

>+      SimpleTest.finish();
>+      return;
>+
>       if (LINUX) {
>         todo(false, "Enable test on Linux - see bug 525175.");
>         SimpleTest.finish();
Comment 9 Serge Gautherie (:sgautherie) 2011-02-26 16:25:50 PST
(In reply to comment #8)
> >+      // Actually, just disable this test everywhere -- bug 586818.
> 
> A |todo(false, ...)| would be better than a comment...

Done in bug 633725.
Comment 10 alexander :surkov 2012-02-05 21:51:17 PST
fixed by bug 719754

Note You need to log in before you can comment on or make changes to this bug.