Remove abandoned and unbuildable extensions/jssh

RESOLVED FIXED in mozilla2.0b8

Status

()

Core
General
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Till M, Assigned: philor)

Tracking

(Blocks: 1 bug)

Trunk
mozilla2.0b8
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b3pre) Gecko/20100802 Firefox/4.0b2pre
Build Identifier: 

Jssh built in server extension missing manifest file

/bu/extract/mozilla-central/config/rules.mk:1875: *** .js component without matching .manifest.  Stop.


Reproducible: Always

Steps to Reproduce:
1. Build mozilla-central with ac_add_options --enable-extensions=default,jssh
Actual Results:  
Doesn't Work!

Expected Results:  
Should Work!

Would be absolutely fantastic if this could be fixed pronto, just wishing out a loud :)
We should probably just remove jssh from the repository. AFAIK it's unowned code.
Component: Build Config → General
QA Contact: build-config → general
(Reporter)

Comment 2

7 years ago
Well that sucks.  Surely someone here can just update it to work with the new way Firefox 4.0 handles extensions.  It works beautifully in beta 2.
I'd do it myself if I new how, but I have no idea how any of his stuff works and the docs are all old :(
Someone could, but it's not something we care about. If someone wants to maintain it, they'd be better off with it in a separate repository, not in mozilla-central. The fact that it exists there at all is a historical accident.
(Assignee)

Comment 4

7 years ago
Created attachment 497041 [details] [diff] [review]
rm

Pretty much what I was going to say in the bug I was going to file before I saw this one: it died sometime between 2006 and 2008, and its not going to come back to life while it's still in the tree.
Assignee: nobody → philringnalda
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #497041 - Flags: review?(ted.mielczarek)
Attachment #497041 - Flags: approval2.0?
Attachment #497041 - Flags: review?(ted.mielczarek)
Attachment #497041 - Flags: review+
Attachment #497041 - Flags: approval2.0?
Attachment #497041 - Flags: approval2.0+
Technically you could just use a=NPOTB, since this totally qualifies.
(Assignee)

Comment 6

6 years ago
http://hg.mozilla.org/mozilla-central/rev/fb5a4e4ce999

Probably obvious to anyone who ought to be trying to maintain jssh, but, to get it back all you have to do is "hg up -r 3ca5d6674feb" and copy it to wherever you're going to work on it.
Blocks: 536237
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED
Summary: jssh server doesn't build → Remove abandoned and unbuildable extensions/jssh
Target Milestone: --- → mozilla2.0b8
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.