After update to Version 3.0.6, Thunderbird startup crash [@ js_InflateString]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Rodrigo, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.126 Safari/533.4
Build Identifier: Version: 3.0.6

The Crash happened when Thunderbird showed a popup that told about the update to the version 3.0.6, I clicked on OK button, and when the Update Finished I clicked on the Thunderbird icon and the problem came up. Now I can't see my emails !

Reproducible: Always

Steps to Reproduce:
1.Update to Version 3.0.6 when Thunderbird tell that a new version came up. Clic OK
2.After the update finish, click on Thunderbird button
3.It never opens and then the Crash Reporter Popup is showed
Actual Results:  
Mozilla Crash Reporter popup came up with the following details:

BuildID: 20100711065956
CrashTime: 1281678288
Email: rodespana@gmail.com
InstallTime: 1281498198
ProductName: Thunderbird
SecondsSinceLastCrash: 378
StartupTime: 1281678256
Throttleable: 1
URL: 
Vendor: 
Version: 3.0.6


Expected Results:  
Update to the new version without any problem.

Comment 1

7 years ago
please post your crash report id described here https://support.mozillamessaging.com/en-US/kb/Mozilla+Crash+Reporter#Viewing_reports_outside_of_Thunderbird
(Reporter)

Comment 2

7 years ago
Hello Wayne,

Here are the crash report id:

bp-f433a0f3-d7be-4352-b17a-56ea32100812
bp-45c76844-5159-41f9-9178-766a72100812
bp-c2947a75-9530-4c77-abff-8afe52100812
bp-2c129f7b-a3f4-42fe-b05d-b08992100811
bp-b9091bab-ccd8-4d43-a36f-9e8f92100810 -> (first crash reported)


I hope this ID's help in something to solve this.


Regards,
Rodrigo

Comment 3

7 years ago
 Rodrigo,
so you updated from 3.0.5 to 3.0.6?
do you crash also in safe mode? 
 https://support.mozillamessaging.com/en-US/kb/Safe+Mode
do you crash with ESET disabled?

Rodrigo's crashes are [@ js_InflateString ]. version 3.1.2 ranking is ~#300.
a) not sure I trust that as a valid signature. could it be something lower on the stack, like nsBaseHashtableET?
b) I see js_InflateString crashes from 3.0.2 to 3.1.2, a high precentage have non-english comments

bp-f433a0f3-d7be-4352-b17a-56ea32100812 is 
0	js3250.dll	js_InflateString	 js/src/jsstr.cpp:3160
1	js3250.dll	JS_CompileScriptForPrincipals	js/src/jsapi.cpp:4659
2	xpcom_core.dll	nsQueryInterfaceWithError::operator	objdir-tb/mozilla/xpcom/build/nsCOMPtr.cpp:75
3	xpcom_core.dll	nsQueryInterfaceWithError::operator	objdir-tb/mozilla/xpcom/build/nsCOMPtr.cpp:75
4	xpcom_core.dll	nsACString_internal::MutatePrep	xpcom/string/src/nsTSubstring.cpp:98
5	xpcom_core.dll	nsAString_internal::Finalize	xpcom/string/src/nsTSubstring.cpp:205
6		@0x456ffc3	
7		@0xb6169f	
8	xpcom_core.dll	nsAString_internal::Assign	xpcom/string/src/nsTSubstring.cpp:361
9	thunderbird.exe	RequestMapEntry::RequestMapEntry	objdir-tb/mozilla/dist/include/necko/nsURIHashKey.h:56
10	thunderbird.exe	nsBaseHashtableET<nsISupportsHashKey,nsCSSFrameConstructor::RestyleData>::nsBaseHashtableET<nsISupportsHashKey,nsCSSFrameConstructor::RestyleData>	objdir-tb/mozilla/dist/include/xpcom/nsBaseHashtable.h:301
11	thunderbird.exe	nsTHashtable<nsBaseHashtableET<nsHashableHashKey,mozJSComponentLoader::ModuleEntry*> >::s_InitEntry	objdir-tb/mozilla/dist/include/xpcom/nsTHashtable.h:406
12	xpcom_core.dll	PL_DHashTableOperate	objdir-tb/mozilla/xpcom/build/pldhash.c:655
13	xpcom_core.dll	nsQueryInterfaceWithError::operator	objdir-tb/mozilla/xpcom/build/nsCOMPtr.cpp:75
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: After update to Version 3.0.6, Thunderbird crash on start and show the Crash Reporter → After update to Version 3.0.6, Thunderbird startup crash [@ js_InflateString]

Comment 4

7 years ago
some js_InflateString Firefox crashes also have JS_CompileScriptForPrincipals in the stack. for example:
bp-27330a13-edb7-4d0d-8c49-94c0d2100829 4.0b2 600sec uptime
bp-0791b3e7-01e0-41de-a329-41f6f2100829 3.5.5

but some do not:
bp-9f023d40-e19a-42b7-a589-a93e12100827
0	js3250.dll	js_InflateString	 js/src/jsstr.cpp:3473
1	js3250.dll	JS_NewStringCopyN	js/src/jsapi.cpp:5261
2	xul.dll	Btoa	js/src/xpconnect/loader/mozJSComponentLoader.cpp:264
3	js3250.dll	js_Invoke	js/src/jsinterp.cpp:1360
4	js3250.dll	js_Interpret	js/src/jsops.cpp:2240
5	js3250.dll	js_Invoke	js/src/jsinterp.cpp:1368
6	js3250.dll	js_fun_call	js/src/jsfun.cpp:1955
7	js3250.dll	js_Interpret	js/src/jsops.cpp:2208
8	js3250.dll	js_Invoke	js/src/jsinterp.cpp:1368
9	xul.dll	nsXPCWrappedJSClass::CallMethod	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1696
Gary ?
I wonder if this is reproducible or if any others has this issue.

Rodrigo, which language of Windows 7 (assuming you're 64-bit) are you on? What language of TB as well?

I see "WARNING: Json file missing Add-ons" under Processor Notes as well, wonder what it means, in bp-f433a0f3-d7be-4352-b17a-56ea32100812

Comment 7

7 years ago
(In reply to comment #6)
> I wonder if this is reproducible or if any others has this issue.

It's not a lone crash - I pmed 4 firefox crashers yesterday.
it is certainly reproducible for some people - check the comment at bp-90a067bf-af5c-4d5a-8e25-859462100821

> Rodrigo, which language of Windows 7 (assuming you're 64-bit) are you on? What
> language of TB as well?
> 
> I see "WARNING: Json file missing Add-ons" under Processor Notes as well,
> wonder what it means, in bp-f433a0f3-d7be-4352-b17a-56ea32100812

normally means startup had not yet got past hooking up add-ons.
not surprising given most of these are startup crashes.
however, bp-90a067bf-af5c-4d5a-8e25-859462100821 is 192 seconds uptime until crash.

Updated

7 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Thunderbird → Core
QA Contact: general → general
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 8

7 years ago
The  Language on my Windows 7 is English, but let me tell you that I started in safe mode, and after that thunderbird downloaded another update and after that it start working again :) .

So, at this moment, I've been working with thunderbird again and the problem is gone.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

7 years ago
Thanks 4 your help to solve this issue.
-> WFM
Resolution: FIXED → WORKSFORME

Comment 11

7 years ago
Rodrigo, can you please isolate and identify for us what is causing the crash?  Is it an add-on/extension is causing the crash?  /(what add-ons are installed?)
Or ESET?
Crash Signature: [@ js_InflateString]
You need to log in before you can comment on or make changes to this bug.