Closed Bug 586887 Opened 11 years ago Closed 11 years ago

bustage on TM tree of Win64 build due to no TrampolineMasmX64.asm

Categories

(Core :: JavaScript Engine, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file)

TrampolineMasmX64.asm is for JM.  We should not add it to Makefile for yarr port.
(Also, I will start to port moo branch for Win64 at next weekend.)
Attached patch fixSplinter Review
Assignee: general → m_kato
Attachment #465569 - Flags: review?
Attachment #465569 - Flags: review? → review?(lw)
Blocks: PortYarr
The moo branch is closed, replaced by http://hg.mozilla.org/projects/jaegermonkey. Win64 support should already exist.
(But if it doesn't - patches welcome. Thanks, Makoto!)
Attachment #465569 - Flags: review?(lw)
(In reply to comment #2)
> The moo branch is closed, replaced by
> http://hg.mozilla.org/projects/jaegermonkey. Win64 support should already
> exist.

Sean, tracemonkey tree is broken now after yarr rand.  This patch is for tracemonkey tree, not JM.
s/rand/land
Comment on attachment 465569 [details] [diff] [review]
fix

This is for tracemonkey tree, not JM.

http://hg.mozilla.org/tracemonkey/rev/597254d97174 is invalid port for Win64.
Attachment #465569 - Flags: review?(dvander)
Attachment #465569 - Flags: review?(dvander) → review+
Land to TM
http://hg.mozilla.org/tracemonkey/rev/27a70c60b48d
Status: NEW → ASSIGNED
Whiteboard: fixed-in-tracemonkey
Duplicate of this bug: 588247
http://hg.mozilla.org/mozilla-central/rev/27a70c60b48d
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.