Checking for updates can mess with the width of the extension list.

RESOLVED DUPLICATE of bug 562924

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 562924
9 years ago
9 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100812 Firefox/3.7a5pre
Build Identifier: 

If you click the "Update Addons Now" button in the new addons manager, and it finds updates to at least one extension, the extension list becomes stretched past the edge of the window, creating a horizontal scrollbar.

It's because the message informing the user that there are updates and that a restart is required is too long for the space available.

This might not even be relevant once the in-content UI lands and the manager's appearance is updated to the latest mockups, but it's present now.

Reproducible: Always

Steps to Reproduce:
1. Size the window so it isn't really wide (I'm on Windows 7, and Firefox is taking about half of the horizontal space on my widescreen monitor.)
2. Open the Addons Manager.
3. Click the "Update Addons Now" button.
4. Have it find an update to an extension (that requires a restart to complete).
5. See that the message in the Manager's header is too wide, causing the list of extensions to be stretched past the window border.
Actual Results:  
List of extensions goes past the edge of the window.

Expected Results:  
The "updates were installed and you need to restart" message should break into two lines if the window isn't wide enough to accomodate it on a single line. This would prevent the extension list from being stretched.

I'm on a recent (within the last 24 hours) hourly build, for what it's worth.
Reporter

Updated

9 years ago
Depends on: 550048
Reporter

Comment 1

9 years ago
This is what I see when I successfully find updates to at least one extension.
Reporter

Comment 2

9 years ago
Oops, dependency was backwards.
Blocks: 550048
No longer depends on: 550048
Reporter

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562924
You need to log in before you can comment on or make changes to this bug.