Note: There are a few cases of duplicates in user autocompletion which are being worked on.

ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html | Check progress increasing: 2796 for seek.ogv

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Mac OS X
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html | Check progress increasing: 2796 for seek.ogv

This came up on a commit that almost certainly did not cause it. I suspect this is an intermittent failure.
(Reporter)

Updated

7 years ago
Blocks: 438871

Comment 1

7 years ago
Bug 584615 will 'fix' this in that progress events will no longer carry the byte information that the test checks for.
Depends on: 584615
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281691250.1281692905.21865.gz
Rev3 Fedora 12 mozilla-central debug test mochitests-1/5 on 2010/08/13 02:20:50

s: talos-r3-fed-044
ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html | Check progress increasing: 8192 for seek.ogv
Dunno why this just started, but it's not related to my recent changes to the cache--I can reproduce this in my day-old nightly build (20100812) pretty easily:

<video onprogress="log(event);" src="http://media.w3.org/2010/05/video/movie_300.ogv" 

controls></video>
<div id="log"></div>
<script>
var last;
function log(e) {
  var log = document.getElementById("log");
  log.innerHTML += e.loaded + " " + e.target + "<br>";
  last = e;
}
</script>

Reloading this a few times, eventually I get:

9197 [object HTMLVideoElement]
8192 [object HTMLVideoElement] << event.loaded has gone backwards
13516 [object HTMLVideoElement]
14968 [object HTMLVideoElement]
16420 [object HTMLVideoElement]

Comment 4

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281727050.1281728785.12701.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitests-1/5 on 2010/08/13 12:17:30

s: talos-r3-leopard-037
53466 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html | Check progress increasing: 2796 for seek.ogv
We discussed this on IRC a while back, but the discussion never made it to the bug.  As doublec pointed out in comment 2, this failure will go away when we remove the I'm recording it here in case we need to deal with this.

GetCachedDataEndInternal reports the data held in mPartialBlockBuffer, but in some cases (e.g. seeking to a new position before the partial block has filled and been committed to cache) this data will be discarded, causing the result of GetCachedDataEndInternal to be lower than an earlier call.  I think this could also happen in other circumstances--for instance, if the end of stream had been downloaded into the cache, but the cache then decided to drop a page at the end of the stream to make space for some other data.
Whiteboard: [orange]
This missed its quota of star spam, since it lacked the essential "orange" in the whiteboard to make it visible to tbpl.

http://tinderbox.mozilla.org/showlog.cgi?log=Birch/1281718050.1281720549.6336.gz
WINNT 5.2 birch debug test mochitests-1/5 on 2010/08/13 09:47:30
s: win32-slave32
49793 ERROR TEST-UNEXPECTED-FAIL |
/tests/content/media/test/test_mixed_principals.html | Test timed out.
52402 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281723683.1281725693.29603.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-1/5 on
2010/08/13 11:21:23
s: talos-r3-snow-004
51253 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 163840 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282287450.1282289936.30016.gz
WINNT 5.2 mozilla-central debug test mochitests-1/5 on 2010/08/19 23:57:30
s: win32-slave37
54901 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282370190.1282372397.29746.gz
Rev3 Fedora 12x64 mozilla-central debug test mochitests-1/5 on 2010/08/20
22:56:30
s: talos-r3-fed64-044
51894 ERROR TEST-UNEXPECTED-FAIL |
/tests/content/media/test/test_play_twice.html | Test timed out.
55273 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 8192 for seek.ogv
TEST-UNEXPECTED-FAIL | Shutdown | application timed out after 330 seconds with
no output
PROCESS-CRASH | Shutdown | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line
for total leaks!

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282494451.1282496665.15376.gz
WINNT 5.2 mozilla-central debug test mochitests-1/5 on 2010/08/22 09:27:31
s: win32-slave33
55609 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1282603398.1282606018.4334.gz
WINNT 5.2 tracemonkey debug test mochitests-1/5 on 2010/08/23 15:43:18
s: win32-slave39
55533 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282615712.1282618563.29373.gz
WINNT 5.2 mozilla-central debug test mochitests-1/5 on 2010/08/23 19:08:32
s: win32-slave38
56412 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1282627285.1282628940.11750.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitests-1/5 on
2010/08/23 22:21:25
s: talos-r3-snow-019
56870 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 8192 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1282690424.1282694549.15216.gz
WINNT 5.2 tracemonkey debug test mochitests-1/5 on 2010/08/24 15:53:44
s: win32-slave18
30492 ERROR TEST-UNEXPECTED-FAIL |
/tests/content/base/test/test_x-frame-options.html | test sameorigin2 - got
true, expected false
51834 ERROR TEST-UNEXPECTED-FAIL |
/tests/content/html/document/test/test_bug446483.html | Test timed out.
55504 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282913284.1282917025.19543.gz
WINNT 5.2 mozilla-central debug test mochitests-1/5 on 2010/08/27 05:48:04
s: win32-slave49
56667 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 2796 for seek.ogv

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282918968.1282922401.13040.gz
WINNT 5.2 mozilla-central debug test mochitests-1/5 on 2010/08/27 07:22:48
s: win32-slave29
56582 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_progress.html
| Check progress increasing: 4096 for seek.ogv
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Disabled the "Check progress increasing" test in test_progress:
http://hg.mozilla.org/mozilla-central/rev/1c826639dd3f
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.