Hang with hr, floated generated content and -moz-column-count

VERIFIED FIXED

Status

()

Core
Layout
--
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: dbaron)

Tracking

({hang, regression, testcase})

Trunk
x86
Windows 7
hang, regression, testcase
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 465640 [details]
testcase

See testcase, which hangs current trunk build. This regressed between 2010-08-04 and 2010-08-08, so I guess a regression from bug 563584.
Assignee: nobody → dbaron
blocking2.0: --- → final+
The infinite loop is in nsColumnSetFrame::ReflowChildren, creating more next-in-flows.
Created attachment 467315 [details] [diff] [review]
patch

The problem was that for the first of the two PushFloatPastBreak calls, we weren't checking the conditions under which we're required to place something in order to avoid an infinite push loop.

This factors those conditions out into a |mustPlaceFloat| variable, and checks them before the first PushFloatPastBreak call.  The |pushedDown| check in the old code is equivalent to the |mustPlaceFloat = PR_FALSE| in the new code, which sets mustPlaceFloat to false when we push down.
Attachment #467315 - Flags: review?(roc)
http://hg.mozilla.org/mozilla-central/rev/5daf8744eed1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
Verified fixed, using:
https://bugzilla.mozilla.org/attachment.cgi?id=465640
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.