all tabs except app tabs disappeared

RESOLVED FIXED in Firefox 4.0b4



Tabbed Browser
8 years ago
8 years ago


(Reporter: dietrich, Assigned: iangilman)


Firefox 4.0b4
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta4+)


(Whiteboard: fixed by bug 586693)


(1 attachment)



8 years ago
i was turning some tabs into app tabs, and suddenly all non-app tabs disappeared.

note: i had not opened tabview at all since restarting the browser.

after the disappearance, i went to tabview, and all my tabs (app + disappeared) were in a stack (not group) in the bottom right-hand corner.

workaround: move all in the stack into a group, open the group. you're back to where you started. except you have to manually re-order the tabs back into position.


8 years ago
Component: TabCandy → Tabbed Browser
Product: Mozilla Labs → Firefox
QA Contact: tabcandy → tabbed.browser
Target Milestone: -- → ---

Comment 1

8 years ago
blocking for investigation. this especially shouldn't happen when someone hasn't opened tabview at all.
blocking2.0: --- → beta4+


8 years ago
Blocks: 586788
I suppose for now, you can skip the manual part with this to put them into one group I believe:

Components.utils.import("resource://gre/modules/Services.jsm"); e = Services.wm.getEnumerator("navigator:browser"); while (e.hasMoreElements()) { w = e.getNext().document.getElementById("tab-view").contentWindow; w.GroupItems.removeAll(); g = new w.GroupItem([], { bounds: { left: 0, top: 0, width: 400, height: 400 }, title: "all pages" }); w.TabItems.getItems().forEach(function(i) { if (i.parent) i.parent.remove(i); g.add(i, null, {animate: false}) }); }

It's basically getting some of the fix from bug 574875.


8 years ago
Blocks: 574875

Comment 3

8 years ago
I believe this will be fixed when we fix 574875.
No longer blocks: 586788


8 years ago
Blocks: 586788
No longer blocks: 574875
Depends on: 574875


8 years ago
Blocks: 587071


8 years ago
Duplicate of this bug: 587001

Comment 5

8 years ago
Still happens in today's nightly
No longer blocks: 587071

Comment 6

8 years ago
This should be fixed by the patch in bug 586693, which landed on Trunk today.
Assignee: nobody → mitcho
Aza suggests that mitcho is unavailable, and Ian should own this. -> Ian
Assignee: mitcho → ian

Comment 8

8 years ago
(In reply to Comment #6)

I don't think the issue has been fixed.
In today's nightly a new window opens with the tab as the only tab. Tab view still shows this tab in the bottom right-hand corner when according to the video on the same interface it should show in the upper left-hand corner. (And other videos such as the one in shows the same thing)
Can you try an hourly build with this fix? What platform are you on? This only happens for *new windows*?
Created attachment 466444 [details]
TabView first run

(In reply to Comment #6)
With nightly 20100816131239 fc2a78c0ac8d and clean profile just now the first TabView run puts the two welcome windows nice and big in the big tab group on the left.
(In reply to Comment #9)

I will try if you give me the hourly build link. I'm on Windows 7. It happens with *new windows* and fresh profiles.

(In reply to Comment #10)
What platform are you on? Could you please send me the link to your nightly so I can try again?
(In reply to comment #12)

Many thanks! I'll try it and I'll get get back to you.
(In reply to comment #12)

Yes, it seems to be fixed even with app tabs it works fine!
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b4
Depends on: 586693
OS: Linux → All
Hardware: x86 → All
Whiteboard: fixed by bug 586693
You need to log in before you can comment on or make changes to this bug.