Hang on windows running a JS demo and dragging the browser window

RESOLVED DUPLICATE of bug 575515

Status

()

defect
RESOLVED DUPLICATE of bug 575515
9 years ago
5 years ago

People

(Reporter: ted, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(URL)

STR:
1) Load the URL provided
2) Drag the browser window by the titlebar

After doing this, my browser is locked up, and it hangs most of my system. The only way out for me is to Ctrl+Alt+Del. That unsticks things until I try to drag the browser again. I attached a debugger while it was hung and the main thread was just deep in JITted code.
blocking2.0: --- → ?
How did you attach the debugger while it was hung? Clicking on Visual Studio (or anything else) has no effect for me when it's hung.
I...don't recall what I did now. That stack may simply be what the browser was doing after I un-hung things using Ctrl+Alt+Del. Remote debugging might be more useful here.

Updated

9 years ago
blocking2.0: ? → final+

Comment 3

9 years ago
On Vista, just Alt+Tab is enough to unfreeze things.

Mozilla/5.0 (Windows NT 6.0; rv:2.0b5pre) Gecko/20100826 Minefield/4.0b5pre NOT Firefox/3.6 - Build ID: 20100826130319
URL now goes to nothing.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
I emailed the author, I'll update if I get a new URL.
The updated URL contains a demo that reproduces the problem. I just tested with my (slightly-out-of-date) 20101113 nightly and can still reproduce the problem.

(The author said he lost the contents of the blog post to a system crash, but this demo is still there.)
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → NEW
I tried again with the new site, and it definitely doesn't work as desired, but I don't get the same behavior as Ted. Instead, it's just pretty laggy as I drag. xperf says our time in this is 18% JS, 15% XUL, 23% nvwgf2um.dll (nvid driver file, apparently), and 27% various Windows graphics dlls, principally d2d1.dll and d3d10_1core.dll.

That, plus the fact that this is Windows-only and we don't recall ever seeing a platform-specific JS-related perf issue of this type, says to me that this is more likely graphics than JS.
Assignee: general → nobody
Component: JavaScript Engine → Graphics
QA Contact: general → thebes
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575515
You need to log in before you can comment on or make changes to this bug.