intermittent mac mochi test leak involving http channel, CloseCookieDBListener and leaking urls containing "seek.ogv"

VERIFIED DUPLICATE of bug 582904

Status

()

VERIFIED DUPLICATE of bug 582904
8 years ago
8 years ago

People

(Reporter: mak, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
this is probably not the right components, provided there is a right component for this leak...

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281720704.1281722375.14285.gz

Leaked URLs:
  http://example.org/tests/content/media/test/dynamic_redirect.sjs?key=v2_96698953&res=seek.ogv
  http://mochi.test:8888/tests/content/media/test/seek.ogv

nsTraceRefcntImpl::DumpStatistics: 1237 entries
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 6914 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 4 instances of AtomImpl with size 20 bytes each (80 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CloseCookieDBListener with size 12 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of Connection with size 100 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 3 instances of DBListenerErrorHandler with size 12 bytes each (36 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of HttpBaseChannel with size 236 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of Service with size 36 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 3 instances of Statement with size 60 bytes each (180 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of StringAdopt with size 1 bytes each (2 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsBaseURLParser with size 12 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 30 instances of nsCStringKey with size 20 bytes each (600 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsCategoryObserver with size 60 bytes each (120 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsCookiePermission with size 36 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsCookieService with size 312 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsDNSService with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsDocShell::InterfaceRequestorProxy with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsEffectiveTLDService with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 30 instances of nsHashKey with size 8 bytes each (240 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsHashPropertyBag with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsHashtable with size 44 bytes each (88 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsHttpChannel with size 396 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsHttpConnectionInfo with size 40 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsHttpHandler with size 340 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsHttpTransaction with size 140 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsIDNService with size 64 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsIOService with size 124 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsInputStreamPump with size 84 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsInterfaceRequestorAgg with size 20 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsLoadGroup with size 8 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsLocalFile with size 136 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsMediaChannelStream::Listener with size 24 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsNetworkLinkService with size 28 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsObserverService with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsPermissionManager with size 92 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsPipe with size 152 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsPrefBranch with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsProxyInfo with size 44 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsRecyclingAllocatorImpl with size 48 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsSocketTransportService with size 1684 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsStandardURL with size 188 bytes each (376 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsStreamConverterService with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 45 instances of nsStringBuffer with size 8 bytes each (360 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 10 instances of nsTArray_base with size 4 bytes each (40 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsThread with size 72 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsTimerImpl with size 72 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsTransportEventSinkProxy with size 32 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsUnicodeNormalizer with size 12 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 17 instances of nsVoidArray with size 4 bytes each (68 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 6 instances of nsWeakReference with size 16 bytes each (96 bytes total)
The leaked URLs sure make it look more like Video/Audio's fault.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 582904
No longer blocks: 438871
V.Duplicate
Status: RESOLVED → VERIFIED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.