If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in layout when loading www.tomshardware.com

VERIFIED DUPLICATE of bug 57026

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 57026
17 years ago
13 years ago

People

(Reporter: joedalton, Assigned: asa)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)
BuildID:    2000103120

Browser crashes with an access violation when trying to load 
www.tomshardware.com


Reproducible: Sometimes
Steps to Reproduce:
1. try to access www.tomshardware.com
2. if it doesnt crash, try resizing the browser window and load the page again.


Actual Results:  Crash with an access violation...        

Expected Results:  load the page successfully.

Comment 1

17 years ago
Confirmed on PC/Linux 2000102921 and 2000103021 trunk builds.
Not seen on 2000102206 build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
OS: Windows NT → All
Summary: Crash when loading www.tomshardware.com → Crash in layout when loading www.tomshardware.com

Comment 2

17 years ago
From the stack trace it looks like this could be a duplicate of the crash on
http://lxr.mozilla.org/seamonkey/source/layout/html/tests/block/bugs/22037.html
mentioned in bug 57026. 
If that's the case, then this bug should not occur with trunk builds before
10/25/2000 19:53, and it should not occur on MN6 builds at all.
Marking this bug dependent on bug 57026 based on the guess. If this one turns
out to be a different problem, please remove it.
Depends on: 57026

Comment 3

17 years ago
Note that this bug is different from bug 58187, which is a crash in necko on 
http://www.tomshardware.de (not .com) and may have to do with plugins.

Comment 4

17 years ago
using a NS6 branch build (103114) on Macintosh, I can't reproduce this crash

Comment 5

17 years ago
I can't reproduce this on Linux 2000-11-01-06.  Someone please post the stack
trace.

Comment 6

17 years ago
Created attachment 18456 [details]
stack trace (not very helpful) from mtrunk/2000103021
(Assignee)

Comment 7

17 years ago
can someone who is experiencing this crash please try a TalkBack build and post
the Incident ID of the TalkBack report.  Thanks. I'm unable to reporduce with
110104 mozilla trunk builds (also tested on yesterday's trunk mozilla build)

Comment 8

17 years ago
Talkback report sent. URL contains tomshardware, description contains bug no.

Comment 9

17 years ago
Created attachment 18495 [details]
better stacktrace, Linux trunk debug build from 11/1 sources
Removing the Cache directory and loading http://www.tomshardware.com/index.html
triggers the assertion in layout/html/base/src/nsHTMLContainerFrame.cpp, l. 356
and then crashes later on line 365.

354       // We should never walk all the way to the root frame without finding
355       // a view
356       NS_ASSERTION(aOldParentFrame && aNewParentFrame, "didn't find view");
357 
358       // See if we reached a common parent
359       if (aOldParentFrame == aNewParentFrame) {
360         break;
361       }
362 
363       // Get the views
364       aOldParentFrame->GetView(aPresContext, &oldParentView);
365       aNewParentFrame->GetView(aPresContext, &newParentView);

This is definitively the same crash as the one jrgm describes in bug 57026 on
http://lxr.mozilla.org/seamonkey/source/layout/html/tests/block/bugs/22037.html
because that page gives me exactly the same stack trace.
(Assignee)

Comment 11

17 years ago
duplicate of bug 57026.  Thanks for the followup Andreas.

*** This bug has been marked as a duplicate of 57026 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
Verified, this is a duplicate of bug 57026 "Crash on a form field when
position:relative."
Status: RESOLVED → VERIFIED
*** Bug 61143 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.