All users were logged out of Bugzilla on October 13th, 2018

Closing a window with hidden Panorama tabs gives an unhelpful dialog box

RESOLVED DUPLICATE of bug 590483

Status

P3
normal
RESOLVED DUPLICATE of bug 590483
8 years ago
3 years ago

People

(Reporter: marcia, Assigned: aza)

Tracking

Trunk
Firefox 4.0
x86
Mac OS X

Details

Attachments

(1 attachment)

Created attachment 465908 [details]
Screenshot of issue

Seen while running Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100813 Minefield/4.0b4pre. Sorry if this is a dupe but I could not find an existing but that describes this exact behavior.

STR:
1. Create two distinct groups in tab candy. One group has one tab, the other has 4 tabs.
2. Change focus back the single normal tab, and press the "X" button

Expected: I would get a dialog asking if I want to close this tab.
Actual: I get a dialog asking if I want to close 5 tabs

The same thing happens if I switch back to the group with four tabs. It want me to close the other window with one tab in it as well.

See attached screenshot.
I agree the text in this dialog could be confusing. Assigning to Aza for his ux/design opinion.
Assignee: nobody → aza
Priority: -- → P4
Duplicate of this bug: 593885
(Assignee)

Comment 3

8 years ago
I'm confused, this is for closing a window with tabs hidden in panorama and having the dialog not mention that some of the tabs are hidden?
(Assignee)

Updated

8 years ago
Summary: Closing a tab using the "X" forces me to close all tabs in distinct groups → Closing a window with hidden Panorama tabs gives an unhelpful dialog box
(Assignee)

Updated

8 years ago
Priority: P4 → P3
Target Milestone: --- → Firefox 4.0

Comment 4

8 years ago
Since this is a Mac bug, I would suggest, in the situation described, that panorama is brought up, without any dialog box coming up.

In Mac the closing of the window doesn't translate in the closing of the application. Then, if you click the panorama window, well, it can continue to do what does now, i.e. not close the program, and in the situation being described, it would bring you back to the last remaining window, the one with 4 tabs in the example.
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590483
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.