Cookie warning dialog in the background unable to be accessed.

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
P3
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: hirata masakazu, Assigned: Stephen P. Morse)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Currently, cookie warning dialog for a window in the back does not come up to
the front.
Therefore, whenever a cookie warning is invoked by a window in the back, the
dialog is hidden by the window in the front.  This makes Mozilla unable to
respond to any user activity bringing it to limbo, especially when the front
window also is dimmed by another cookie or other warning dialog.
Any dialog that disable other user input should be brought to the front.
2000103120 MTrunk and other recent builds.

Comment 1

17 years ago
This worksforme with 110104 Mozilla trunk build on Mac OS9
Here's what I did to test. Tell me if I'm not doing the right thing (and please
include clear steps to reproduce in future bug reports)
1. Open two Browser windows both with about:blank loaded
2. Set prefs to warn before accepting a cookie
3. type cnn.com in the addressbar of one window which will load a page that will
prompt for cookie acceptance.
4. quickly bring second browser window (the one still at about:blank) to front.

When I do this I see the cookie warning dialog pop up in front of the frontmost
window.
When you do this you do not see a cookie warning dialog because it is between
the back and the front window?  Is this correct?
(Reporter)

Comment 2

17 years ago
I know I did not specifically list the way to reproduce it, because I could not
see the actual dialog, and did not know which window was causing it.
What I am pretty sure so far is that you have to have more than one window with
multiple frames each of which trying to get your attention, thus making the
front most window/dialog unresponsive.
I will try to find exact steps to reproduce this.

Comment 3

17 years ago
hirata masakazu, have you done any more investigation on this one?
(Reporter)

Comment 4

17 years ago
I have not come up with a repoducible one.
My impression is the bug has since fixed, because the multiple cookies dialogs
now appear in two alternate positions so that the most recent one is reacheable
and the next one is visible.  This was not the case before.
Marking as WFM on that ground.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
verified wfm
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.