Display the Firefox button when in TabView

RESOLVED FIXED in Firefox 4.0b4

Status

defect
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: fryn, Assigned: fryn)

Tracking

Trunk
Firefox 4.0b4
x86
Windows 7
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [in-litmus-bug-week])

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

9 years ago
Currently our browser window XUL hierarchy looks like this:

<window>
  ...
  <deck>
    <vbox>
      <!-- everything in the UI except Tab Candy, incl. Firefox button -->
    </vbox>
    <iframe id="tab-view"/><!-- ohai, this is Tab Candy -->
  </deck>
  ...
</window>

So, in order to bring back the Firefox button, we'll probably need to rearrange the XUL hierarchy to move the Firefox button out of the deck.

Updated

9 years ago
Depends on: 581820
Assignee

Comment 1

9 years ago
Posted patch patch (obsolete) — Splinter Review
pulls the firefox button out of the xul:deck.

also includes a temporary margin-top for tab view to leave some space between the firefox+min/max/close buttons and tab view.
Attachment #465952 - Flags: review?(dolske)
Assignee

Updated

9 years ago
Attachment #465952 - Flags: approval2.0?
Assignee

Updated

9 years ago
Blocks: 587279
Comment on attachment 465952 [details] [diff] [review]
patch

Just move the deck down, right before <toolbox id="navigator-toolbox"...?
Attachment #465952 - Flags: review?(dolske) → review-
Assignee

Comment 3

9 years ago
Posted patch patch v2Splinter Review
Attachment #465952 - Attachment is obsolete: true
Attachment #466083 - Flags: review?(dao)
Attachment #466083 - Flags: approval2.0?
Attachment #465952 - Flags: approval2.0?
Attachment #466083 - Flags: review?(dao) → review+
Duplicate of this bug: 587279
No longer blocks: 587279
Attachment #466083 - Flags: approval2.0? → approval2.0+

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/e81d421e99ed
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b4
Blocks: 587209
We want a test case in Litmus for this.
Flags: in-litmus?
Added to Litmus:
https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=12847
Flags: in-litmus? → in-litmus+
Whiteboard: [in-litmus-bug-week]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.