Context menus rendered with transparent backgrounds in FF 4.0b3

RESOLVED INVALID

Status

()

Core
XP Toolkit/Widgets: Menus
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Alex Sirota (iosart), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Discovered while testing PlainOldFavorites with FF 4.0b3.

Windows 7, 64bit

Steps to reproduce:
1. Install PlainOldFavorites 1.1 from here: http://www.iosart.com/firefox/plainoldfavorites/PlainOldFavorites_1.1.xpi   (UNRELEASED VERSION, PLEASE DO NOT RE-DISTRIBUTE) 
2. Locate the 'Favorites' menu in the main Firefox menu bar (might need to show it with FF 4)
3. Click on Favorites to show the menu
4. Right click on any menuitem within the Favorites menu

Result: a context menu appears, but it has no (or transparent) background, no border etc - only the actual menuitem text is visible

Expected result: context menu should be rendered correctly, with background, border etc.
(Reporter)

Comment 1

8 years ago
btw - the context menus are attached using the 'context' attribute to each menuitem in the 'Favorites' menu
Hardware: x86 → x86_64

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578441

Comment 3

8 years ago
This isn't a dupe. That bug is for Thunderbird.

Comment 4

8 years ago
INVALID
1. Working (or broken) as designed.
2. Extension problem, not Firefox nor Toolkit nor Core.
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.