Crash in a WebGL demo [@WebGLContext::CompileShader] [@yyparse]

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: scoobidiver, Assigned: vlad)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100813 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100813 Minefield/4.0b4pre

The WebGL demo that was working in FF 4.0b3 now crashes Minefied after "Loaded texture : pluto".

Graphic card : GMA 4500M
Graphic driver version : 8.15.10.2182

Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
http://crash-stats.mozilla.com/report/index/bp-80288a2e-4360-4767-b2a9-9fdf92100814

Signature	yyparse(void*)
UUID	80288a2e-4360-4767-b2a9-9fdf92100814
Time 	2010-08-14 03:06:50.215963
Uptime	1493
Last Crash	233305 seconds (2.7 days) before submission
Install Age	74146 seconds (20.6 hours) since version was first installed.
Product	Firefox
Version	4.0b4pre
Build ID	20100813041308
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x38

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	yyparse 	gfx/angle/generated/glslang_tab.cpp:2187
1 	xul.dll 	PaParseStrings 	obj-firefox/gfx/angle/glslang.cpp:2683
2 	xul.dll 	ShCompile 	gfx/angle/src/compiler/ShaderLang.cpp:200
3 	xul.dll 	mozilla::WebGLContext::CompileShader 	content/canvas/src/WebGLContextGL.cpp:2866
4 	xul.dll 	nsICanvasRenderingContextWebGL_CompileShader 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:25042
5 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4713
6 	mozjs.dll 	js::InvokeCommon<int > 	js/src/jsinterp.cpp:588
7 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:691
8 	mozjs.dll 	js::InternalInvoke 	js/src/jsinterp.cpp:754
9 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4836
10 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2248
11 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:228
12 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1106
13 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1202
14 		@0xa3bf26f
Summary: Crash in a WebGL demo [@ yyparse(void*) ] → Crash in a WebGL demo [@WebGLContext::CompileShader]
Thanks for the bug report.

Vlad: this is yet another crash in CompileShader, and his build is from this Friday, August 13, so it shouldn't be the same crash that you already fixed.
Created attachment 466033 [details] [diff] [review]
string fix

Two problems here -- one is a string problem on our end, but fixing that revealed a crash in the shader validator.

This is a patch for the first problem, and I've filed the second upstream as http://code.google.com/p/angleproject/issues/detail?id=24
Assignee: nobody → vladimir
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #466033 - Flags: review?(bjacob)
Comment on attachment 466033 [details] [diff] [review]
string fix

These seem like unrelated changes and would be better split into two patches.
Attachment #466033 - Flags: review+
(Reporter)

Updated

9 years ago
Status: NEW → ASSIGNED
Attachment #466033 - Flags: review?(bjacob) → review+
The string fix was checked in, but leaving this open to track the upstream crash.
blocking2.0: --- → betaN+
Summary: Crash in a WebGL demo [@WebGLContext::CompileShader] → Crash in a WebGL demo [@WebGLContext::CompileShader] [@yyparse]
Duplicate of this bug: 588275
Should be fixed by ANGLE update.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.