Smiley face not shown in "Message Display" prefs in classic theme

VERIFIED FIXED in mozilla0.9

Status

P2
normal
VERIFIED FIXED
18 years ago
11 years ago

People

(Reporter: brane, Assigned: andreww)

Tracking

Trunk
mozilla0.9

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

18 years ago
There's a buglet in the Classic theme: the prefpanels.css stylesheet is missing
from the skin, so the smiley face isn't shown in the "Message Display" pane. I
just copied the file and binding from the Blue theme. Here's a patch.

diff -rc bin/chrome/classic/skin/classic/communicator/communicator.css
Seamonkey/chrome/classic/skin/classic/communicator/communicator.css
*** bin/chrome/classic/skin/classic/communicator/communicator.css	Wed Aug 23 18:38:06 2000
--- Seamonkey/chrome/classic/skin/classic/communicator/communicator.css	Wed Nov  1 17:12:51 2000
***************
*** 13,18 ****
--- 13,19 ----
  @import url(chrome://communicator/skin/brand.css);
  @import url(chrome://communicator/skin/menubutton.css);
  @import url(chrome://communicator/skin/formatting.css);
+ @import url(chrome://communicator/skin/prefpanels.css);
  @import url(chrome://communicator/skin/toolbar.css);
  /* should we put this here, or make a dialog include it specifically? */
  @import url(chrome://communicator/skin/search-widgets.css);
diff -cP bin/chrome/classic/skin/classic/communicator/prefpanels.css
Seamonkey/chrome/classic/skin/classic/communicator/prefpanels.css
*** bin/chrome/classic/skin/classic/communicator/prefpanels.css Thu Jan  1
01:00:00 1970
--- Seamonkey/chrome/classic/skin/classic/communicator/prefpanels.css   Wed Nov
1 16:29:26 2000
***************
*** 0 ****
--- 1,21 ----
+ /********** Fonts ***************/
+
+ #sizeVar, #sizeMono {
+       width: 4em;
+ }
+
+ #mouseWheelMode {
+       width: 9em;
+ }
+
+ /******* SmartBrowsing **********/
+
+ #disabledDomains {
+       max-height: 13em;
+ }
+
+
+ .smileface
+   {
+     list-style-image : url("chrome://messenger/skin/smile.gif");
+   }
confirming, and over to themes.
Assignee: matt → hangas
Status: UNCONFIRMED → NEW
Component: Preferences → Themes
Ever confirmed: true
QA Contact: sairuh → pmac

Comment 2

18 years ago
Sending to Andrew
Assignee: hangas → andreww

Comment 3

18 years ago
*** Bug 55002 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 4

18 years ago
We're willing to check in the code for this bug. Is anybody interested 
in getting this fixed?
jessica, that'd be great! pls attach a patch to this bug and add the
patch/review keywords to get onto someone's radar for review/checkin... thx!

Comment 6

18 years ago
Created attachment 20203 [details] [diff] [review]
Added prefpanels.css to the jar file

Comment 7

18 years ago
Created attachment 20204 [details]
prefpanels.css  -same as in blue and modern theme

Comment 8

18 years ago
Created attachment 20205 [details] [diff] [review]
Added prefpanels.css to classic\communicator\makefile.win

Comment 9

18 years ago
Created attachment 20206 [details] [diff] [review]
Added prefpanels.css to classic\communicator\MANIFEST

Comment 10

18 years ago
Created attachment 20207 [details] [diff] [review]
Added prefpanels.css to communicator.css

Updated

18 years ago
Keywords: patch, review
(Assignee)

Comment 11

18 years ago
Ok, I see the patches and I will try them out and get them checked in.
(Assignee)

Updated

18 years ago
Priority: P3 → P2

Comment 12

18 years ago
Themes Triage Team nsbeta1+
Keywords: nsbeta1
(Assignee)

Comment 13

18 years ago
setting milestone.
Target Milestone: --- → mozilla0.8

Comment 14

18 years ago
Moving to 0.9
Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Comment 15

18 years ago
Created attachment 25110 [details] [diff] [review]
new patch - for mac and windows classic.
(Assignee)

Comment 16

18 years ago
ready for review, I think...

Comment 17

18 years ago
r=hangas

Comment 18

18 years ago
sr=hewitt
(Assignee)

Comment 19

18 years ago
Fix checked into the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
Marking verified on all platforms (2001-03-05-08-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.