Website's alias trigger google location bar search

RESOLVED DUPLICATE of bug 565966

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 565966
9 years ago
9 years ago

People

(Reporter: vladmaniac, Unassigned)

Tracking

unspecified
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Steps: 
1. Focus location bar by click or keyboard shortcut and type 
in one of the known websites alias ("personas" for mozilla themes page, 
"cnn", for cnn.com. "aol" for aol.com) 

================================================================================

Expected: 

Typed alias should open directly appropriate page. 

================================================================================

Actual: 

Typed alias triggers a google search for input string.
(Reporter)

Updated

9 years ago
blocking2.0: --- → ?

Comment 1

9 years ago
That is the normal behavior of the location bar - if it's not a DNS name, Google will be used to search for the word. Or it will go directly to the correct website if it's confident that the first found item in google's list is the one you want.

See http://support.mozilla.com/en-US/kb/Location+bar+search?s=search+location how to switch it off.

I'm not sure what you mean with alias - how would you create such aliases ? Do you mean the keyword field in the bookmarks properties ? Or the tags that you can add to a bookmark ?
(Reporter)

Comment 2

9 years ago
Please check this litmus testcase https://litmus.mozilla.org/show_test.cgi?id=10072 which was a pass until 8/12/2010 timestamp minefield pre build. 

However, I apologize for the "alias" term which can be ambiguous. I'm sure that the testcase will make things clear.

Comment 3

9 years ago
I can see that in Firefox 3.6.8, 'personas' goes directly to the page, while 'lotr' goes to the search page. In Minefield, both go to the search page.

That's controlled by the 'browse by name' feature mentioned on <http://kb.mozillazine.org/Location_Bar_search>. But that is changed in Firefox 4.0, as part of the 'paper cuts' bugs, see bug 565966.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565966
blocking2.0: ? → -
You need to log in before you can comment on or make changes to this bug.