switch to tab does not allow you to create a new instance of that page

VERIFIED DUPLICATE of bug 568161

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 568161
7 years ago
7 years ago

People

(Reporter: Reece H. Dunn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [switch-to-tab])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre

If you have a tab open to a url, and want to open a new tab to that url, typing the address in the awesome bar results in the "Switch to Tab" link with no way of opening it in the current tab.

Reproducible: Always

Steps to Reproduce:
1. Navigate to a url in tab A (e.g. www.google.co.uk)
2. Open a new tab (tab B)
3. type in the url for tab A in tab B (e.g. www.google.co.uk)
Actual Results:  
The awesome bar shows a "switch to tab" result in the awesome bar (switching to tab A), but does not allow you to navigate to that url in tab B.

Expected Results:  
There should be an option to open the link in the current tab, spawning a new instance.
Component: General → Location Bar
QA Contact: general → location.bar
alt-enter opens an url in a new tab also in this case.

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

7 years ago
alt-enter is not a viable option..  Example

1. I press Ctrl-T to open a new tab
2. type a few letters of the boookmark I wish to open a second tab for
3. press "Alt-enter" (non-obvious)
4. and I have a NEW NEW tab (the new tab created in #1 is still there)

Why can't there be an about:config option at minimum to disable this thing.
yeah, the extra blank in that case is inconvenient. There's bug 595046 on that

Comment 4

7 years ago
requiring me to press "Alt-enter" is equally inconvenient as well..  More often than not I am opening tabs to the SAME page that I already have open (in my case it's a SQL query form I use for debugging).  This has become a significant annoyance and impairs my ability to use FF4.   simply adding in a about:config option at minimum to disable the behavior would be extremely welcome as I see no purpose for finding a tab that way, when I can already click on the ""group your tabs" button to search my tabs. (which I personally never use either as it just gets in the way)

Updated

7 years ago
Blocks: 480350

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 568161
Whiteboard: [switch-to-tab]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.