Helper apps don't launch

VERIFIED FIXED

Status

P3
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: jkobal, Assigned: jkobal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CMVC32831)

(Assignee)

Description

18 years ago
If you configure a helper application for a certain extension/mime type, then 
try to open a file of that type, the helper application is not launched.

The problem is that nsLocalFileOS2.cpp uses the NSPR function 
PR_CreateProcessDetached to launch the helper, and that function uses DosExecPgm 
to create the new process.  However, since MOZILLA.EXE is marked as a VIO 
application (WINDOWCOMPAT) to display the console window, PM applications can't 
be launched via DosExecPgm (which can only start a process of the same type as 
the caller).

Since a helper application might be ANY type (VIO, PM, VDM, etc.), we should not 
be using DosExecPgm to launch it; therefore, we should not be calling the NSPR 
API to do this.  Instead, nsLocalFileOS2::Spawn should call DosStartSession to 
launch the program.

I already have a fix ready for this problem.

Comment 1

18 years ago
SCREENED.  VERIFIED AS VALID.
Whiteboard: CMVC32831
Assign
Status: NEW → ASSIGNED
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
Verified - fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.