Random hang (command timed out) in test_cookies_read.js

RESOLVED DUPLICATE of bug 595925

Status

()

defect
RESOLVED DUPLICATE of bug 595925
9 years ago
5 years ago

People

(Reporter: standard8, Unassigned)

Tracking

({intermittent-failure})

Trunk
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
On the Thunderbird Linux tinderboxes we're seeing a fairly frequent xpcshell-test hang in test_cookies_read.js:

TEST-INFO | /buildbot/linux-comm-central-check/build/objdir/mozilla/_tests/xpcshell/test_cookies/unit/test_cookies_read.js | running test ...

command timed out: 300 seconds without output, killing pid 11417
process killed by signal 9
program finished with exit code -1
TinderboxPrint: xpcshell-tests<br/><em class="testfail">T-FAIL</em>
buildbot.slave.commands.TimeoutError: command timed out: 300 seconds without output, killing pid 11417
TinderboxPrint: xpcshell-tests<br/><em class="testfail">timeout</em>

http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1281983292.1281987477.22382.gz

Unfortunately that's all the information I have at this stage.

Comment 1

9 years ago
We haven't seen anything like this on Firefox. Not sure what could be different here. What network.cookie prefs are your tests using?
(Reporter)

Comment 2

9 years ago
We use the default prefs. We do have some mailnews specific code, but not sure why that would cause an issue.

I've tried locally on my mac and not been able to reproduce, will try on a Linux VM soon.
(Reporter)

Comment 3

9 years ago
I've tried reproducing this today, all I've been able to see so far is that the close after removing some cookies can take up to 40 seconds or so - which seems like a potential deadlock area.

This is the line where it was temporarily hanging:

http://hg.mozilla.org/mozilla-central/annotate/c1bb86ae655a/extensions/cookie/test/unit/test_cookies_read.js#l73

Comment 4

9 years ago
Pretty sure this will be fixed by bug 595925. Reopen if you're still seeing this after that lands?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595925

Updated

9 years ago
Blocks: 438871
(Reporter)

Updated

9 years ago
Duplicate of this bug: 601508
Whiteboard: [orange]
seems the problem is back https://tbpl.mozilla.org/php/getParsedLog.php?id=25758311&tree=Mozilla-Inbound
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Oh, no wonder the summary of this seems a little off for what we're starring it as, it's an entirely different thing from years ago that shouldn't have been reopened. Filed bug 966713.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595925
You need to log in before you can comment on or make changes to this bug.