All users were logged out of Bugzilla on October 13th, 2018

No text shown when all panels deleted

RESOLVED FIXED in Future

Status

P3
normal
RESOLVED FIXED
18 years ago
14 years ago

People

(Reporter: mikepinkerton, Assigned: jon)

Tracking

({helpwanted, polish, regression})

Trunk
Future
helpwanted, polish, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The Delete All Panel Test for sidebar says:

"Expected Results: After step 3, the pane on the right should be blank. After
step 4, no panels should be listed in the Sidebar and a mesage saying " The
Sidebar is currently empty.....and select Sidebar"  should appear"

There is no text in the 10/31/00-14 branch build. All platforms.
(Reporter)

Comment 1

18 years ago
hardly a stop-ship, but then again i never know these days.
Keywords: polish, rtm
(Reporter)

Updated

18 years ago
Keywords: regression

Comment 2

18 years ago
can't hold for this...
Assignee: matt → blakeross

Comment 3

18 years ago
rtm-, definitely not a stop ship.
Whiteboard: [rtm-]

Comment 4

18 years ago
Putting on the mozilla 0.9 radar as a "simple fix needed" bug.
Keywords: mozilla0.9

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: mozilla0.9
Target Milestone: --- → mozilla1.0

Comment 5

18 years ago
bigger things to worry about.
Assignee: blakeross → matt
Status: ASSIGNED → NEW

Comment 6

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Updated

17 years ago
Keywords: helpwanted
Target Milestone: mozilla1.0 → Future

Comment 7

17 years ago
*** Bug 108207 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
--> sgehani
Assignee: matt → sgehani
(Assignee)

Comment 9

14 years ago
Created attachment 155224 [details] [diff] [review]
possible fix

This restores the empty sidebar text, and doesn't break the sidebar AFAICT. 
I.e. the test in comment 0 as well as addition/removal/hiding/showing of panels
still works for me.  

Regarding the offending line: |this.node| is "sidebar-panels" when that
statement is hit.

Here's the checkin that introduced that code.  It occurred about a month and
half prior to this PR, but is the most likely candidate for causing this bug.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/xpfe/components/sidebar/resources&command=DIFF_FRAMESET&file=sidebarOverlay.js&rev2=1.64&rev1=1.63
(Assignee)

Updated

14 years ago
Attachment #155224 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #155224 - Flags: review?(doronr)

Updated

14 years ago
Attachment #155224 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+

Updated

14 years ago
Attachment #155224 - Flags: review?(doronr) → review+

Comment 11

14 years ago
mozilla/xpfe/components/sidebar/resources/sidebarOverlay.js 	1.123
Assignee: samir_bugzilla → jon
(Assignee)

Comment 12

14 years ago
FIXED
thanks!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.