The default bug view has changed. See this FAQ.

file:// does not work correctly in Webclient

VERIFIED FIXED

Status

Core Graveyard
Java APIs to WebShell
P3
normal
VERIFIED FIXED
17 years ago
5 years ago

People

(Reporter: Ashu Kulkarni, Assigned: Ashu Kulkarni)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
When file:// is used to access the local filesystem in Webclient, no files get
displayed, although the content area does draw the panels for displaying files.

This bug shows up on Win NT and Solaris.
(Assignee)

Comment 1

17 years ago
Created attachment 18484 [details] [diff] [review]
diff -u for CBrowserContainer.cpp
(Assignee)

Comment 2

17 years ago
I accept.

This bug shows up, because the CBrowserContainer does not implement the
DocShellTreeOwner::GetPrimaryContentShell function. The posted attachment fixes
this problem.

Ed, pls verify this fix.

thanks
_Ashu
Status: NEW → ASSIGNED
(Assignee)

Comment 3

17 years ago
Created attachment 18523 [details]
tar of modified files - untar in java/webclient
(Assignee)

Comment 4

17 years ago
Patch modifies

src_moz/CBrowserContainer.cpp

Comment 5

17 years ago
r=a=edburns.
(Assignee)

Comment 6

17 years ago
Fix checked in. Closing Bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
This bug is still reproduced on FCS-candidate(from 11/30/2000)
(Assignee)

Comment 8

17 years ago
The Fix for this Bug is in the RTM Branch. However sicne we are using the PR3 
build for the FCS candidate, this fix will not be in the FCS bundle. There is 
no need to reopen this Bug.

Comment 9

16 years ago
Verified. I cannot reproduce this bug with Mozilla 0.9.1 under win 
NT (Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1) Gecko/20010915) 

Updated

16 years ago
Status: RESOLVED → VERIFIED

Comment 10

16 years ago
Mark VERIFIED according to Vladimir's comment.
Work under Solaris too. 
Component: Java APIs to WebShell → Java APIs to WebShell
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.