deleting IMAP folder crashes application

VERIFIED DUPLICATE of bug 58748

Status

P3
major
VERIFIED DUPLICATE of bug 58748
19 years ago
10 years ago

People

(Reporter: cls, Assigned: mscott)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Subject says it all.  To reproduce: click on any sub-folder of INBOX and delete
it.  Warning: if you test this with gdb, use the 'delete' key to delete the
folder instead of the menu item or you risk the chance of freezing the X
server's event loop.  

The problem appears to be that

rv = GetTrashFolder(getter_AddRefs(trashFolder));

fails on line 1686 but there's no check for a failure condition.  And then we
dereference that pointer at line 1695.  Crash. Boom.
(Reporter)

Updated

19 years ago
Keywords: crash
(Assignee)

Comment 1

19 years ago
This is a dup of 58748 which just got fixed.

*** This bug has been marked as a duplicate of 58748 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe based on buster's Nov. 1 analysis in bug 58748.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.