If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong definition in CSS for Thunderbird

RESOLVED FIXED in 1.6

Status

Mozilla Labs Graveyard
Personas Plus
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
On creating a patch for Thunderbird (Bug 545557) I've found a bug in Personas:

#messengerWindow[persona] #tabmail, .tabmail-tabs {
  background-color:transparent !important;
}

The comma after #tabmail should be removed. Like it is now .tabmail-tabs background-color is always transparent also when no persona is applied. With removing this comma all works as expected.

This definition is used in linux (line 70), winxp and vista (both line 80).
(Assignee)

Comment 1

7 years ago
Created attachment 530289 [details] [diff] [review]
Patch fixing this issue

Chris I nowhere found who is the right person for r?, so I take you.
Attachment #530289 - Flags: review?(cbeard)

Comment 2

7 years ago
dmose?
Assignee: cbeard → dmose
I asked dmose about this earlier in the week, and he suggested andreas.  cc'ing him now.

Updated

6 years ago
Attachment #530289 - Flags: review?(cbeard) → review?(dmose)

Updated

6 years ago
Attachment #530289 - Flags: review?(dmose) → review?(nisses.mail)
Comment on attachment 530289 [details] [diff] [review]
Patch fixing this issue

I could not reproduce this issue (probably because lwthemes are build into Thunderbird now), but the patch applies cleanly to the personas checkout and looking at the css the comma have no place in there.
Attachment #530289 - Flags: review?(nisses.mail) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/labs/personas/rev/cd6e8e8ccecc

Thanks for the patch!
Assignee: dmose → richard.marti
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
OS: Windows 7 → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.6
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.