[PP]Linux- default Character Set menu does not fit in Window

VERIFIED DUPLICATE of bug 9276

Status

()

Core
XUL
P2
major
VERIFIED DUPLICATE of bug 9276
18 years ago
2 years ago

People

(Reporter: Teruko Kobayashi, Assigned: saari (gone))

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DEPEND - Intl)

(Reporter)

Description

18 years ago
Tested 5-03-99 Linux 2.0 build.

When you select menu View|Default Character Set, the selection of Character set menu is not fit in the Windows.
Below Korean (EUC-KR) is not shown.  This is very critical for I18n.

I do not know who I need to assigned to.
(Reporter)

Updated

18 years ago
Priority: P3 → P2
Target Milestone: M6

Updated

18 years ago
QA Contact: 3853 → 3851

Updated

18 years ago
Summary: Linux - Default Character Set menu does not fit in Window → [PP]Linux- efault Character Set menu does not fit in Window

Comment 1

18 years ago
Putting on [PP] radar.
(Reporter)

Updated

18 years ago
Assignee: don → trudelle
Component: Apprunner → XP Toolkit/Widgets
Summary: [PP]Linux- efault Character Set menu does not fit in Window → [PP]Linux- default Character Set menu does not fit in Window
(Reporter)

Comment 2

18 years ago
*** Bug 6041 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
As I mentioned in the duplicate bug, this seems to be a general
GTK menu scroll issue. If there are other menu items which need to
scroll, they will also fail to display entirely.

For testing purposes, we need a resolution of this bug or an easy workaround.
(I don't think editing and re-ordering .xul should be considered an
easy workaround for testers.)

Updated

18 years ago
Assignee: trudelle → saari

Comment 4

18 years ago
reassigning to saari.
(Assignee)

Comment 5

18 years ago
Ramiro, how did you do the hierarchical menus for this case before? I don't see
any GTK APIs that will accomodate this.
(Assignee)

Updated

18 years ago
Target Milestone: M6 → M7
(Assignee)

Comment 6

18 years ago
Here are Owen's comments on the issue, FYI:

saari@netscape.com (Chris Saari) writes:

> So what is the best way to handle menus that have more items than can be shown
> on the screen? On other OSes the menu auto scrolls, is there a plan for GTK to
> do this?
>
> I know this is bad UI design, please don't flame me for that, I don't control it.

Unfortunately, this has simply never been implemented. It's not
fundementally hard to do; its just that the people with the knowledge
to do it have never really needed the feature, and it is just
a bit to messy to do from an abstract feeling that it should
be there. Patches would be appreciated (though GtkMenu* is
rather scary code.) Otherwise, hopefully its something I'll
have time to do at some time before GTK+-1.4.

My personal fealing is that scrolling is better than continuation
menus. Certainly better than continuation menus where you have to
go all the way to the button of the screen to access the
next column - like the Motif continuation menus.

You could add continuation menus by hand as submenus, though it might
not come out looking quite perfect; that's probably the easiest way to
do it without modifying GTK+.

Regards,
                                        Owen

Updated

18 years ago
Whiteboard: DEPEND - Intl

Updated

18 years ago
Blocks: 7228

Comment 7

18 years ago
i'll hop on the bandwagon for this one
(Assignee)

Updated

18 years ago
Target Milestone: M7 → M9
(Assignee)

Comment 8

18 years ago
I don't think this is going to make it for M7 no matter what, so I'm pushing it
to M9.

Updated

18 years ago
No longer blocks: 7228
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
marking this as a duplicate

*** This bug has been marked as a duplicate of 9276 ***

Comment 10

18 years ago
I thought it is a practice to mark later bugs of the same
problem as duplicates rather than the first one.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
Verified Duplicate...see Bug 9276
https://hg.mozilla.org/projects/cypress/rev/46a36152ca47
You need to log in before you can comment on or make changes to this bug.