Back and Forward buttons not working as expected

RESOLVED DUPLICATE of bug 588200

Status

Firefox for Android Graveyard
General
--
major
RESOLVED DUPLICATE of bug 588200
8 years ago
8 years ago

People

(Reporter: ahoza, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Environment:

Device: Nokia N900
BuildId: Mozilla/5.0 (X11; Linux armv7l; rv:2.0b4pre) Gecko/20100817
Namoroka/4.0b4pre Fennec/2.0a1pre

Device: HTC Desire A8181
BuildId: Mozilla/5.0 (Android; Linux armv7l; rv:2.0b4pre) Gecko/20100817
Namoroka/4.0b4pre Fennec/2.0a1pre

Scenario1:

1. Start Fennec
2. Visit two successive sites.
3. Tap "Back"
4. Tap "Forward"

For this scenario everything works as expected.

Scenario 2:  


1. Start Fennec
2. Visit 3 successive sites.
3. Tap "Back" twice

Expected results:
Content for first accessed page is displayed.

Actual results:
When tapping "Back" for the second time, browser hangs; it looks as if is trying to load something, but that something is never displayed.
(Reporter)

Comment 1

8 years ago
Scenario 2 described above works (or this time I've tried it did), but the process is real slow (pages load heavily)
For the blow I get the actual results described above:

1. Access google.com; cnn.com and digg.com.
2. Tap "Back" twice in the browser.
3. Tap "Forward" twice in the browser.

Actual results:
When tapping "Forward" for the second time, browser hangs; it looks as if is
trying to load something, but that something is never displayed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588200
You need to log in before you can comment on or make changes to this bug.